Search results

  1. ronaldst

    SSL error for www -version of domain

    This is resolved. The www-version of the domain was not included in the LE SSL. Problem was solved by expanding the current SSL to include the www-version of the domain.
  2. ronaldst

    SSL error for www -version of domain

    I have applied only one certificate, the one from Let's Encrypt 'certbot'. I am not sure how to check if this includes the www-version of the domain, I always imagined it would. Am I wrong here?
  3. ronaldst

    SSL error for www -version of domain

    I have problems with SSL I can't seem to figure out. The www-versioin of my domain returns a SSL error. In the configuration of my virtual host I've set "Domain Name" to example.com, and added www.example.com as "Domain Alias". The listener is configured to listen to "example.com". When I open...
  4. ronaldst

    Google Search Console - HTTPS Failure

    I can not figure out what is causing this error. It is still not resolved. I have tried inspecting the SSL in different browsers and online tools, where none of them reports any errors. However, I did a SEO audit using semrush.com, and it reports the following error: "Certificate registered to...
  5. ronaldst

    Google Search Console - HTTPS Failure

    I run a website on OLS and recently Google Search Console is reporting HTTPS failure. I have installed SSL and all content is running on HTTPS. I have also redirected all HTTP traffic to HTTPS to be sure noone browse the website without encryption. Have anyone else experienced this and able to...
  6. ronaldst

    Rapid 404/301 access.log errors when LSCache for WordPress is enabled

    I run OpenLiteSpeed 1.6.17 on CentOS 7 + LSPHP 7.4. I recently noticed that enabling the LiteSpeed Cache -plugin on my WordPress site is cusing a very high load on the server. Further investigations I find a rapid growing access.log with these types of errors: "IP.IP.IP.IP - -...
  7. ronaldst

    Error 404 when adding a new virtual host.

    Hard to say what may be the cause of this without more information. I usually always check file permissions first. This seem to be the main cause I run into regards to 404.
  8. ronaldst

    Module:Cache vary request header "Origin" not defined

    I got a few WordPress -sites running on a VPS with CentOS 8 + OLS. After a closer look on my logfiles I noticed multiple entries similar to this: 2020-06-05 21:07:44.873828 [WARN] [178.154.200.123:33918-1#domain.com] [Module:Cache] vary request header "Origin" not defined! I am using the...
  9. ronaldst

    Empty error logs for virtual host

    Have anyone been able to run separate error logs for a virtual host? Is sharing the main server log the only option?
  10. ronaldst

    Empty error logs for virtual host

    I'm having some problems understanding why my virtual host error logs are empty. [user@server]# /usr/local/lsws/bin/lshttpd -v LiteSpeed/1.6.1 Open module versions: modgzip 1.1 cache 1.61 modinspector 1.1 uploadprogress LSIAPI_VERSION_STRING...
  11. ronaldst

    Protect against wp-login attacks

    Im investigating a issue where a few websites I run on OLS is being targeted by wp-login attacks. While doing some research how to best handle this I read that LiteSpeed got native WordPress protection. Are there any similar solution available to OLS? Is this something OLS reCaptcha would...
  12. ronaldst

    Possible to add additional IP addresses to server

    You first need to add your ip's to the operating system. Once added you will see them when doing 'ifconfig' or 'ip a' in the command prompt. Once you have them available in the OS they are also available in the OLS control panel - and can be assigned to specific listeners.
  13. ronaldst

    Proper procedure/configuration of OLS as proxy

    You are missing the point. Im not willing to make a compromise, it will either be done or it won't.
  14. ronaldst

    Proper procedure/configuration of OLS as proxy

    Setting context as / will not work as example.com is used as for a large website. Is it not possible to proxy the localhost server to a diferent url than the root domain?
  15. ronaldst

    Proper procedure/configuration of OLS as proxy

    I have recently moved from Apache to OLS and am trying to learn as much as possible. Recently I've stumbled upon a issue using OLS as proxy infront of netdata - a localhost webserver running on port 19999. I would ultimately like to access netdata from example.com/netdata. From what I could...
  16. ronaldst

    Is it possible to install OLS 1.5.4 from yum repositories

    Awesome. Thank you for pointing me in the right direction.
  17. ronaldst

    Is it possible to install OLS 1.5.4 from yum repositories

    I'm currently running OLS 1.4.9 on CentOS7 (installed from the litespeed repositories). Is it possible to install or preferably upgrade to 1.5.4 from the repositories?
  18. ronaldst

    "No request delivery notification has been received from LSAPI application, possible dead lock."

    I've tested it and it does not resolve the error/lockup. Logs are showing multiple entries of: No request delivery notification has been received from LSAPI application, possible dead lock However, this might not be a OpenLiteSpeed problem for all I know. It could be a PHP configuration issue...
  19. ronaldst

    "No request delivery notification has been received from LSAPI application, possible dead lock."

    I am not using DirectAdmin, if that is what "DA" refers to. I'm on a CentOS 7 minimal with MariaDB and OpenLiteSpeed + PHP 7.3. I am using 2 workers on this VPS and have 2 workers. I've probably set max connections and children too high, however, I doubt this is related to that as I'm far from...
  20. ronaldst

    "No request delivery notification has been received from LSAPI application, possible dead lock."

    Did you find a solution for this? I am experiencing the same problem on a WordPress site I recently moved to a VPS running OpenLiteSpeed. This error can be reproduced when saving changes to a file in the built-in theme and plugin editor in WordPress. Tailing the error logs shows multiple...
Top