Search results

  1. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    Thanks everyone who tried to help. Turns out it was in fact on my hoster side (their DDoS protection blocked UDP on 443).
  2. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    I've asked my hosting provider and currently waiting for response. sudo ss -tulpn shows that OpenLiteSpeed listens to port 443. I've tried to update Rocky Linux to 8.7. It didn't solve the issue. However when I tried to host another website on another hosting with the same vhosts configs and...
  3. Rinart73

    (DELETE)

    Good day. I'm trying to install OpenLiteSpeed on AlmaLinux 8.7. I'm following this instruction: https://openlitespeed.org/kb/install-ols-from-litespeed-repositories/ [root@server ~]# rpm -Uvh http://rpms.litespeedtech.com/centos/litespeed-repo-1.1-1.el8.noarch.rpm Retrieving...
  4. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    I tried completely disabling iptables and firewalld. It didn't solve the issue.
  5. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    I reverted to 1.7.15 and upgraded to 1.7.16 again. HTTP 3 still doesn't work and https://http3check.net/?host=https%3A%2F%2Fproseosite.com%2F still says connection couldn't be established (honestly they could've given more info there).
  6. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    Will reverting to 1.7.15 and then upgrading to 1.7.16 reset any of my webadmin or vhosts configs?
  7. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    I can't get it to work even on IPv4. I'm on the last stable version. In the headers I see QUIC but Chrome dev tools says I'm using HTTP 2: alt-svc: h3=":443"; ma=2592000, h3-29=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q043=":443"; ma=2592000, quic=":443"...
  8. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    But I allowed it via Firewall-CMD and I'm sure that's the app that manages my traffic. And when I'm testing from another machine I'm getting: > nc -z -v proseosite.com 443 Connection to proseosite.com (185.205.209.84) 443 port [tcp/https] succeeded! > nc -z -v -u proseosite.com 443 Connection to...
  9. Rinart73

    HTTP 3/QUIC stopped working, website is now using HTTP 2

    I can't pass http3check.net test (https://http3check.net/?host=proseosite.com) and in the Chrome dev console (Network tab) I'm seeing HTTP/2 and not 3. I'm pretty sure that some time ago HTTP 3 was working fine. Website: proseosite.com OpenLiteSpeed version: > /usr/local/lsws/bin/lshttpd -v...
  10. Rinart73

    Almalinux 8.6 failed to update ImageMagick-libs

    Having the same issue. Managed to install ImageMagick itself and it works. Hovewer can't install lsphp80-pecl-imagick module. Saw somewhere that maybe the module points to the wrong/old ImageMagick libraries?
  11. Rinart73

    Can't install lsphp80-pecl-imagick: nothing provides libMagickCore

    I've installed the ImageMagick itself via: dnf install epel-release dnf config-manager --set-enabled powertools dnf install ImageMagick but I'm getting the same error when I try to install php module
  12. Rinart73

    Can't install lsphp80-pecl-imagick: nothing provides libMagickCore

    I have Rocky Linux 8. All packages are up to date. I'm trying to install Imagick for OpenLiteSpeed PHP 8.0: dnf install lsphp80-pecl-imagick and getting the following: Error: Problem: conflicting requests - nothing provides libMagickCore-6.Q16.so.6()(64bit) needed by...
  13. Rinart73

    How to protect Web Admin - maybe reCAPTCHA?

    I'm looking for ways to protect my web admin. I chose complicated password, changed default "admin" login and switched web admin port. Hovewer even though the chances are low, I'm still worried about bruteforce. I want to to know if there any other ways to protect web admin. Allowing to connect...
  14. Rinart73

    How to make static context still execute document-level rewrites?

    Yeah I tried it. But the LSCache plugin just replaces .jpg with .jpg.webp in HTML via filters. That rewrite doesn't seem to do anything. UPD: No matter how hard I tried, it seems that .htaccess rewrite rules are completely ignored if a file hits "Context" rules. Idk why. I'm very new to...
  15. Rinart73

    How to make static context still execute document-level rewrites?

    I'm running Wordpress with WebP Express plugin and trying to serve WebP instead of JPEG and PNG for browsers that support it. It started working after I found a way to enable reading .htaccess in subfolders (since the rules are in the "/wp-content/uploads/" folder). Hovewer the problem is that...
  16. Rinart73

    SSL certificate marked as secure for www and insecure without www

    I got Let's Encrypt certificates for both versions: with and without www. Hovewer for some reason Chrome thinks that my non-www version is insecure (even though certificate is valid) while version with www is secure. Can anybody help to resolve this? I'm willing provide more info. OpenLiteSpeed...
Top