Recent content by stevieosaurus

  1. stevieosaurus

    Custom Error Pages with proper HTML code

    Same, however my issue was not with which 403 page is returned but which HTTP code is returned when specifying a custom page in the web admin - namely the (correct) 403 code when NO custom page specified and a 301 code (redirect) when you have a custom page in the web admin. My request was so...
  2. stevieosaurus

    Custom Error Pages with proper HTML code

    Scenario: Need to set custom error page for a domain/virtual host, let's assume for FORBIDDEN content, with return HTML code 403 - which is vital being received & logged, as it plays into blocking such consecutive requests via modSecurity module. The rewrite code in question which blocks...
  3. stevieosaurus

    minor visual bug: duplicate help text

    Not very important but might be easily fixed - some help/tutorial text appears twice when "Edit" is being accessed. This one is from the Rewrite section, but also happens elsewhere.
  4. stevieosaurus

    Smarter sub/domain virtualhost hierarchy

    May I suggest-request a more logical and efficient way of configuring virtual hosts in future versions of OLS, as to having a tree structure hierarchy between domains and their subsequent subdomains. This would greatly simplify VH configuration, creation/addition, maintenance and updates while...
  5. stevieosaurus

    OLS 1.9.1 webAdmin loses features

    Yes, not it updates to v.1.9.1 and the "Create" button one again appears when a missing config file is detected. Thank you. Haven't checked out the rest of the settings in having default values set once again, but anything helping ease and automate the creation of new settings helps.
  6. stevieosaurus

    OLS 1.9.1 webAdmin loses features

    doesn't seem to be :)
  7. stevieosaurus

    OLS 1.9.1 webAdmin loses features

    Still does the same, Dashboard displays 1.9.1. BUILD July 1st and the RPSM repo (CENTOS 9) seems to be still from July 5th. https://rpms.litespeedtech.com/centos/9/x86_64/RPMS/
  8. stevieosaurus

    OLS 1.9.1 webAdmin loses features

    I got it as an automatic package update on Alma Linux (RHEL) bulked along with the other OS updates. From the official repo I suppose, CENTOS (/9 or /10) https://rpms.litespeedtech.com/centos
  9. stevieosaurus

    OLS 1.9.1 webAdmin loses features

    That one. See attached screenshot. Got a different error message in 1.9.1: "Please create manually."
  10. stevieosaurus

    OLS 1.9.1 webAdmin loses features

    Since the release of v1.9.1 when creating a virtual host the vh config file missing initially show an error in the WebAdmin. In all previous versions you were notified it is missing (not yet created) and have been given a very convenient option for OLS to create it for you with 1 single click...
  11. stevieosaurus

    Hide server IP

    Indeed it does give a 403 now. The previous test was my bad, didn't have the host root well configured. Thank you.
  12. stevieosaurus

    Hide server IP

    Nope, it still shows the OLS's default 404 page. I also put * in the Denied List, set Per Client Throttling all to 1 (lowest value), it still shows 404 page instead of making it inaccessible or at least show a 403 (Forbidden / access denied). Any other suggestions? OLS v1.9.0 btw.
  13. stevieosaurus

    ZSTD compression

    May we please get clearer delimitation/control sttings in the OLS webadmin (Tuning - Compression section) of the static & dynamic pages compression options? Right now is very confusing, for ex: in order to have Brotli compression applied (only towards static files permitted) the settings need...
  14. stevieosaurus

    ZSTD compression

    Following up on this request, as v1.9 has been released for a while, with an addition if I may: Having different compressions (ZTSD & Brotli) for STATIC files compared to having them served as GZIP will be extremely welcome, yet what would be even greater to have these options also for DYNAMIC...
  15. stevieosaurus

    ERROR - Packet size is too large ?

    Soon after upgrading to OLS v1.8.4 it works for a while, but in a few hours client sees "The connection has timed out" while the error log displays: What might be causing this? Attached: Server Configuration > Tuning settings
Top