Help getting Plausible Analytics to run /w Openlitespeed - possibly reverse proxy related?

Hi guys,

maybe someone can help me.

I'm currently running an Ubuntu 20.04 VPS with Cyperpanel and the newest version of Openlitespeed. I've managed to install Docker for Plausible analytics based on this guide here. I've also issued the SSL for my The plausible.conv is editable correctly as well.

Further down in the guide it refers to NGINX, but I assume I need to convert those steps for Litespeed.

But from what I've read there needs to be a reverse proxy (to be honest I don't really have a solid understanding what that is, but it seems to be important sometimes ;) ) and I don't know how to set that up?

I'm fairly new to self-hosting, so I'need more details steps so I can re-create them in the Openlitespeed admin interface.

Can anyone help? Please also let me know what info you need in order to help. I'd be happy to provide that.
I got it to run on the MYIP:8000. However, I'm still unsure about how to setup a proxy on OLS as the links provided confuses me what setup I need and the end just leave me hanging. e.g. "it's assumed you setup ...."
I think I'm getting somewhere - at least when I use the context method.

Where I'm trying to get to is that if I put in or httpS:// is always defaults to the secure site with SSL cert (httpS://

Issue I'm still having
I can now access plausible analytics via, but not without the port number I get a 500 error. Maybe you can guide to through the steps that I'm missing. I'd need easier to follow steps, as most guides confuse me.

There are so many option in so many places and as noob to get an understanding what settings does what is extremely overwhelming. : (

Anyway, here are my current settings that work via

And I've already edited my docker-compose.yml as stated by the Plausible self-hosting instructions here under no. 2.

After setting up a reverse proxy be sure to change this line - 8000:8000 to - in docker-compose.yml file and restart the container for it to apply changes. This prevents Plausible from being accessed remotely using HTTP on port 8000 which is a security concern.

My docker-compose.yml is now set to:

My server config, external app for Plausible
CleanShot 2023-09-18 at 20.30.04@2x.jpg
My other external apps
CleanShot 2023-09-18 at 20.29.47@2x.jpg
CleanShot 2023-09-18 at 20.29.32@2x.jpg

Rewrite is on, and the rewrite is done in Cyberpanel --> next pic
CleanShot 2023-09-18 at 20.29.12@2x.jpg

My rewrite rule set for
CleanShot 2023-09-18 at 20.28.48@2x.jpg

Added the context for proxy vhost
CleanShot 2023-09-18 at 20.34.31@2x.jpg

Overview of my listeners
CleanShot 2023-09-18 at 20.30.51@2x.jpg

CleanShot 2023-09-18 at 20.31.43@2x.jpg
CleanShot 2023-09-18 at 20.32.01@2x.jpg
CleanShot 2023-09-18 at 20.33.19@2x.jpg

Last picture in my next post as limit are 10.

In this guide here in method 3 is says:
>Assume we have set up both port 80(apachehttp) and 443(apachehttps) External Applications.

Where should I add the external applications? Under server config, under virtual host,....There are so many places where I as a noob could add them. That's really confusing, as I don't understand how the whole things is supposed to work.
Last edited:


The rewriterule method should be good enough, no need to add a context.
If you want to respond HTTPS only, then the current rules are incorrect, please use the following example only:
RewriteRule ^(.*)$ HTTPS://Plaxxxxx/$1 [P,L,E=PROXY-HOST:xxxxxxx]

If is still not working, please submit a ticket to with this forum post link appended.