Switching PHP version in Web Server Control Panel causing error

#1
Hello, I'm using OpenLiteSpeed Wordpress from AWS marketplace and I have a problem on switching PHP versions.
When I'm at Web Server Control Panel choosing version 7.4 and click "Next" to switch on this version is shows error "error [object Object]"
I'm using the most updated version.
Do you have any of this errors or solution for it?
 

conor

New Member
#5
I'm having the same problem after upgrading from Ubuntu 18.04 to 22.04, and in /usr/local/lsws/logs/stderr.log I see:

Code:
[STDERR] curl: try 'curl --help' or 'curl --manual' for more information
It seems the curl command being used to fetch the PHP sources is wrong or being misinterpreted by the shell.
 
#8
I found this in my log

PHP:
[13927] [IP:port:HTTP2-125#_AdminVHost] [STDERR] PHP Fatal error: Undefined class constant 'MEMCACHE_VERSION8' in /usr/local/lsws/admin/html.open/lib/util/build_php/buildfunc.inc.php on line 692
 
#10
@bonecrusher
Still, no ticket received, could you help to submit the issue to support@litespeedtech.com with this forum link appended? Also, the reproduce steps. So our dev team can check the issue. Thanks.
I just submitted a ticket. I think the issue might have been when I restored my WordPress manually, I accidently copied files I was not supposed to copy to my /www/html site.
Thanks for following up on this Cold-Egg.
 
#12
Thanks for the report, we will update the result here.
As per support staff recommendation/suggestion, I created a new ubuntu instance with cyberpanel then installed wordpress. It's much easier and hassle free to change the php version (upgrade/downgrade) through the cyberpanel. I did not know you can install wordpress through cyberpanel!! Here is my email to support this morning:

I installed cyberpanel yesterday for wordpress and so far I like cyberpanel. You're right, I can upgrade/downgrade php version so easily. I wish I had known about cyberpanel. You see in Linode, when I search the marketplace for wordpress, cyberpanel does not show up!! It only shows two options to install wordpress, through litespeed and standalone wordpress. Maybe you should contact Linode and ask them to include cyberpanel when people search the marketplace for wordpress.
Thank you guys!!
 

Cold-Egg

Administrator
#13
In case anyone wants to know, here's the finding from our dev team,

For the PHP Fatal error from web admin console, there is a typo in that build. You can manually update this file:
/usr/local/lsws/admin/html.open/lib/util/build_php/buildfunc.inc.php line 692, change MEMCACHE_VERSION8 to MEMCACHE8_VERSION

This will be fixed in the next release, sorry for the trouble.
 
#14
In case anyone wants to know, here's the finding from our dev team,

For the PHP Fatal error from web admin console, there is a typo in that build. You can manually update this file:
/usr/local/lsws/admin/html.open/lib/util/build_php/buildfunc.inc.php line 692, change MEMCACHE_VERSION8 to MEMCACHE8_VERSION

This will be fixed in the next release, sorry for the trouble.
cool!! this is great.....
 
Top