unset Etag Problem - Please Help



So open litespeed has no htaccess so we set rules in control panel.

I have unchecked all three etag settings under server setting however it does not disable.
Header unset ETag
FileETag None

However since open litespeed does not I can't... I have tried to add Header unset ETag.. FileETag None.. in litespeed control panel in rewrite section but it throws error.

How can I disable Etag in open litespeed.
Last edited by a moderator:


Yes seems to be bug in not only open lightspeed but commercial version as well. Solution they give is put.. Header unset ETag FileETag None in .htaccess. But we cant with open version so hoping there is another way to set this header in open lightspeed.
commercial version is ok -- I did tests before.
I think this has to be a feature request for current open litespeed:
ETAG and/or header unset

if you want to resolve it in shortest time, you may have to modify the source code, remove ETAG related code, then rebuild open litespeed.