Wordpress Cache (W3 or WP Super Cache) XML Files

Afternoon All,

I have been trying for a while now to get my head around the tutorials for making the WordPress caches work on my website properly, but utilising the XML config files as detailed on your tutorials.

EDIT (link to W3 tutorial) - http://open.litespeedtech.com/mediawiki/index.php/Help:How_To_Set_Up_W3_Total_Cache_With_Template

I am however running into difficulty at the first hurdle, when I am told that the config file cannot be XML and must be a ".CONF" file. I have changed the extension (clutching at straws) that the format would be the same, but to no avail. Can someone explain if these need updating, are no longer needed, or if indeed I am doing something wrong please?

Many Thanks,



Hi Danny,

Apologies, that tutorial is outdated. OLS 1.3 used xml, and we switched to plain conf from 1.4 forward. The template file will have to be updated to be a plain conf configuration (similar to the server configs) rather than xml based.

We are working on getting an xml to plain conf converter working so that this may be updated.

If you are interested, we do have a litespeed cache plugin as well that integrates with the cache module.

I'll update you when the conf file is updated.

Hi Kevin,

Thanks for the reply.

Glad to hear it's not me. I don't like to post on here if I can help it in case it's just me being silly, but in this case I see it was worth while :)

Please do keep me updated as to if/when it will be updated/working.

I think I might have tried the litespeed plugin, but it came up with some errors of it's own regarding write permissions, even though it has written what it needed to in the wp-config file. I then assumed this was only for litespeed and not OLS. Should this work in harmony with the normal cache module then?

Thanks in advance,



Hi Danny,

Working on uploading the two conf files, they should now work (hopefully the conversion worked :D)

Regarding the litespeed plugin, it should be mostly compatible with OLS's cache module. There are some kinks that need to be worked out (e.g. some settings will edit the .htaccess file. This is not an OLS feature, so OLS will have to be restarted for the new .htaccess code to take affect), but overall it should be able to work with it.

We're working on adding a wiki entry on how to set it up if you're interested. If not, the conf files should be available soon-ish.
I'll try both, see what gives the best results. I'm always up for trying these things out.

Just changed things today, switched off the OLS cache and put varnish in front. Had to switch the keep-alive off to get it working reliably, but seems ok, not as great as I was expecting for a stand alone cache, but then again it could be configured wrong, I am a bit of a newb.

Thanks for the reply, I'll keep my eyes peeled for the new configs.


Well, I've installed the WP Super Cache one which is working without a hitch (http://it-assist.co.uk/) can view here, check source =

<!-- Dynamic page generated in 0.244 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2016-07-28 15:57:05 -->
<!-- Compression = gzip -->
Hi Rob,

The one thing I'm coming up when trying to follow your new tutorial is the "Context" tab....I have a static context setup to re-write my phpadmin. but the vhost itself is already setup to point to wordpress, what context should i be creating? or how to I apply the htaccess rewrite rule elsewhere?




Hi Danny,

That rewrite rule line needs to go into the context/vhost that is associated with wordpress. Meaning if index.php is in a context, the rewrite rule should go there. If it's in a vhost, it can go in the vhost rewrite config.

I hope this is clear, let me know if that did not help. (In a weird state of mind at the moment :D)

Sorry - I realised how silly I was being eventually. Got it working now, running at Litespeed :D Feel free to check out the results below:

Web server Unknown
HTTP response code 200
Server Address http://it-assist.co.uk
connection close
content-encoding gzip
content-type text/html; charset=UTF-8
date Thu, 28 Jul 2016 18:59:50 GMT
link <http://wp.me/P7yAoC-6y>; rel=shortlink
transfer-encoding chunked
vary Accept-Encoding
x-litespeed-cache hit
x-litespeed-cache-control public,max-age=1800
x-litespeed-tag F,P.406,B.1
Time to contact web server 0.368574 seconds

Thanks guys,



No need to be sorry, we're always looking to have clear instructions, so we'll clarify this soon-ish.

Going at LiteSpeed! Let us know if you run into any issues

EDIT: will be releasing a new version of the plugin shortly, just as a heads up :)
Will do, thanks to both of you for the hard work and input on the new caching methods. Really appreciated.

Is the update due on wordpress or on litespeed itself?