Recent content by Rudi

  1. R

    wont bind to port 80 or 443

    @Cold-Egg do you have a guide handy on how to use OLS to do this rather than PM2 ?
  2. R

    Performance difference for OLS using difference linux distro's?

    Hi All, Has anyone had experience with OLS across different Linux distro's - for example does using Cento 7 or Ubuntu result in faster page loads ? Maybe because the distro is lighter, better tuned or what ever the reason might be? Im interested in loading dynamic PHP based pages as fast...
  3. R

    Redirect whole domain except 1 directory

    This syntax seems to work best with OLS: RewriteCond %{REQUEST_URI} ^!\.well-known/
  4. R

    Redirect whole domain except 1 directory

    Its to do with the . in the directory name ! I can get it to work with !/well-known/ but not !/.well-known/
  5. R

    Wordpress Wordfence .user.ini / auto_append_file

    fixed. I was using append instead of prepend when putting in php.ini: auto_prepend_file = "/usr/local/lsws/www/wordpress/wordfence-waf.php"
  6. R

    Redirect whole domain except 1 directory

    Thanks for the suggestion, I combined the HTTPS and WWW that worked nice, but moving RewriteCond %{REQUEST_URI} !/.well-known/ up didn't work. I also tried RewriteCond %{REQUEST_URI} ^!/.well-known/ as well.
  7. R

    Wordpress Wordfence .user.ini / auto_append_file

    Hi All, I use wordfence to protect my wordpress site. One of the functions is It checks the code before executing it. It does this by appending a file called .user.ini. In litespeed enterprise it just picks up the .user.ini file and wordfence works. in OLS it didnt pick the file up so i put...
  8. R

    Redirect whole domain except 1 directory

    Hi all, I am trying to redirect a whole domain except 1 directory - this is the code i have: RewriteEngine On RewriteCond %{HTTP_HOST} !^www\. [NC] RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteCond %{HTTPS} off RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI}...
  9. R

    wont bind to port 80 or 443

    Thanks Kevin, got it to work - there was something else on the port - the logs helped
  10. R

    wont bind to port 80 or 443

    Hi all, Just wondering if anyone knows how to solve this: I have a node.js app running using pm2 to keep alive and i want to use openlitespeed to reverse proxy. But i cant get openlitespeed to work on a port below 1024 - it just wont work - even though its open in the firewall. port 8080...
  11. R

    Too many open files

    hi all, I am randomly getting an error that my port 80 listener "can't accept: too many open files" Anyone seen this before or have an idea on how to fix it ? Ps I can never seem to be able to upload images (server error) on this forum
  12. R

    Openlitespeed Cache Module

    Last question, should opcache be turned off when using litespeed cache module ?
  13. R

    Openlitespeed Cache Module

    Thank you for help Kevin; There is a setting called "IS INTERNAL" when i chose yes and it worked!
  14. R

    help with rewrite

    Im not sure if i am doing the right thing; some background: I am using an extension in magento for amazon cloudfront (content delivery network) The extension change's the image url from...
  15. R

    Openlitespeed Cache Module

    Hi Kevin, that didnt seem to help from what i can see;
Top