1.4.4 OLS vs FireFox 35.0/35.01

Discussion in 'OpenLiteSpeed Bug Reports' started by Tracy Perry, Jan 27, 2015.

  1. Tracy Perry

    Tracy Perry Active Member

    OK, got a complaint from a user that he could no longer connect to my MC site using FireFox 35.0.1. Had him regress to 35.0 of FireFox and the problem continued. He was using Windows 7 Pro SP1.

    I got onto my desktop that is the same OS and confirmed that I could not connect to the site at all using FireFox. I could connect fine using Chrome or Safari (from the Mac) and IE 11 and Chrome from the Windows box. I did NOT think to check Mac version of FireFox (had several things going on).

    Once I regressed back to OpenLiteSpeed 1.4.3 the connections were fine - so something has changed.

    I'm running SSL on the site, compiled with --enable-spdy and --with-group=nogroup (I'm on Debian Wheezy).
    PHP is at version 5.6 and is the same compile options used with 1.4.3 of OLS.

    I am using XenForo 1.4.4 on the site in question.
  2. lsmichael

    lsmichael Active Member

    Hey Tyler,

    What's the site URL? (Does MC stand for "motorcycle"? Because I'm from Brooklyn and here it stands for "master of ceremonies" and usually involves being able to rhyme well.) Perhaps it's a, gulp, HTTP/2 implementation issue...

  3. lsmichael

    lsmichael Active Member

  4. Tracy Perry

    Tracy Perry Active Member

    Yep.. and yep, motorcycle. AKA donorcycle.
    I've regressed to 1.4.3 so it's working for my users... but I'm pretty sure that it's a HTTP/2 issue with FireFox.

    If you want to co-ordinate I can switch to 1.4.4 of OLS so you can see what's going on from a user end - or I can copy the DB over to a test VPS and set it up... or even create a duplicate of the VM and just change the IP address.
    Last edited: Jan 28, 2015
  5. lsmichael

    lsmichael Active Member

    Ah, yes, donorcycles. Y'all are such good samaritans.

    Thanks for the offer, Terry. We may take you up on it. I'll be in touch soon.

  6. Fearless

    Fearless Member

    Are Tyler and Terry short forms for Tracy? Is this some sort of inside joke? LOL. :p
    lsmichael likes this.
  7. lsmichael

    lsmichael Active Member


    Wow. That's impressive. Tracy, how many times did I get your name wrong? Have I been doing this on other forums too?

    Fearless likes this.
  8. lsmichael

    lsmichael Active Member

    But now I will do it intentionally. (If you don't mind.)

  9. Tracy Perry

    Tracy Perry Active Member

    It happens frequently enough that I answer to just about anything and got away from calling folks on it as it tended to embarrass them. So don't worry about it. After being married for 32 years, as I said, I answer to just about everything. :D
    lsmichael and Fearless like this.
  10. lsmichael

    lsmichael Active Member

    Alright, Trevor. We need to take you up on one of your offers. We can't reproduce the problem. Can we organize a time to test it with your site (or a copy of your site)?

  11. Tracy Perry

    Tracy Perry Active Member

    I'll set up another VPS instance and transfer the site data over to it and see if I can replicate it there. Otherwise, I'll have to do an "upgrade" to 1.4.4 again on the live site.
    Just ship me a convo and we will see if we can't co-ordinate a time to do it and I can set up an admin account for y'all to access OLS with.
  12. lsmichael

    lsmichael Active Member

    Convo started.

  13. lsmichael

    lsmichael Active Member

    Hey Tracy,

    So the conversation kind of stalled a little while back. Have you had a chance to try any of the installs since 1.4.4?

  14. Tracy Perry

    Tracy Perry Active Member

    Have had to go back to nginx temporarily since I've had a serious problem with a site hotlinking images and hogging bandwidth and never could get hotlink prohibition to work on OLS like with nginx. Then when I upgraded to OLS 1.4.5 it down doesn't honor the FURL's that did work with OLS prior to that. I'm going to have to work on the FURL problem before I can get it back online.
  15. lsmichael

    lsmichael Active Member

    Rewrite problem perhaps? Did you copy and paste Apache rewrites?

  16. Tracy Perry

    Tracy Perry Active Member

    Nope, they were ones that were working.
  17. Tracy Perry

    Tracy Perry Active Member

    I've gotten the rewrites to work.. and everything works fine in Safari (on my Mac), but when I try to hit my site with Chrome, I get the ERR_SPDY_PROTOCOL_ERROR error shown. No matter what I do. Firefox won't even show an error.
    I've got SPDY/2, SPDY3 & HTTP/2 enabled.

    Needless to say, since I can't get it to work for 2 out of 3 browsers, I've gone back to nginx for now (again).

    It may be due to compiling on Debian instead of the standard CentOS/RedHat configs that are typically used for OLS/LiteSpeed.


    OK, looks like 1.4.6 solved the problem I was having... now I just need to work on preventing general hotlinking but allowing it to certain domains.

    EDIT #2

    And the hotlink problem is solved also.
    Last edited: Mar 23, 2015
  18. Fearless

    Fearless Member

    You might be one of the rare ones on Debian using OLS. :p I like Debian myself, and was thinking of trying it with OLS, but I was afraid of any extra bugs (and also no official repo) heh.
  19. Tracy Perry

    Tracy Perry Active Member

    Yeah... now for some reason with 1.4.5 and using memcached and Zend OPCache and BDCache I get display problems with one of my add-ons. I'm going to keep playing with it, but for day to day use I've had to switch back to nginx. My users (what few there are) were complaining and I don't want to run them off!

    It may also be an issue with OLS and Chrome.
    Here is my site under Chrome

    And here it is (at the same time) under Safari

    Well, appears I can't attach images... but suffice to say, the version under Chrome has ALL the CSS stripped from it.
    Last edited: Mar 26, 2015
  20. lsmichael

    lsmichael Active Member

    I'm sorry to hear that. Have you narrowed down what might be causing it. That's quite a few variables you have there.


Share This Page