403 on virtual host

#1
Have set up OLS on Ubuntu 22, but seem not to have the permission settings correct on my docroot folder/files.

I've matched ever setting to the Example vhost, but get a 403 error when visiting the site. If I point the listener at Example, it works.

Also, if I change the DocRoot to a non-existent folder, I get (as expected) a 404. Point at the real one, and it's 403.

What's best practice for folder/file ownership when installing vhost folders under lsws?

Or could something else be wrong?
 
#3
HI,
This one should help you to set up a virtual host with the correct permission, https://docs.openlitespeed.org/configuration#set-up-virtual-hosts
The document root permission will depend on you, if the server runs with www-data, then you can just use it. If you have multiple users with different user/group, then the setup will be slightly different.

About 403, you might want to check the error log, it should give you the 403 reasons.
 
#4
Thank you very much for the link.

I've followed those steps and created a new VH - with the docroot in my /home/ubuntu/www folder.

However, I have the same 403 error. Which log do I look in for more info on this? Neither lsws/logs/access.log or lsws/error.log contain anything that gives me a clue.
 
#5
This is in my errror.log:

2022-11-21 08:06:34.743579 [NOTICE] [32256] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 998 gid 65534 setuidmode 2.
2022-11-21 08:06:34.743614 [INFO] [32256] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 998 gid 65534 setuidmode 2.
2022-11-21 08:06:34.743622 [NOTICE] [32256] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, fin>
2022-11-21 08:06:34.744216 [NOTICE] [32256] [AdminPHP] add child process pid: 32284
 
Top