404 after subdomain redirect to new openlitespeed digital ocean droplet


I decided to give OLS a go considering the great benchmarks. I installed one click wordpress installation on DO.

I am not an expert on webhosting, so I would kindly ask for a help with my issue.

I already have a domain `www.goldenonestaffing.com` that I inherited from before. Now while developing, I wanted to redirect beta.goldenonestaffing.com to my IP . When I go to the website directly from IP address, everything works great. But when I redirected, I got 404. I tried permanent and temporary redirect in google domains. I didnt try editing dns record directly.

any advice on what should I try?


assuming that you have configurated everything fine with www.goldenonestaffing.com domain on your DO box.
Now you want to point beta.goldenonestaffing.com to the above server, you can add that domain to lisener 80 and 443 at virutal host for www.goldenonestaffing.com to take both "www.goldenonestaffing.com, beta.goldenonestaffing.com" domains.

For testing purpose, Override your windows hosts file as the following and visit beta.goldenonestaffing.com to see if it works or not. beta.goldenonestaffing.com

If it works, then you can change your dns setting poiting beta.goldenonestaffing.com to
If not work, need to check your DO and find our why.
Ok, I didn't quite get everything here.

goldeonestaffing.com is pointed to my old website, so I dont know how I need to configure it on my new digital ocean.

how is now the procedure to create beta.goldenonestaffing.com to point to the new DO

DO currently works at
Do I need to add new listener in ols admin panel or new virtual host?

thank you


"goldeonestaffing.com is pointed to my old website" do you mean you did not set up goldeonestaffing.com on your new server?

Which domain did you setup on your new server? beta.goldenonestaffing.com?

configuring a virtual host and domain are basic steps to do first before you want to setup any redirect.

Refer to our knowledge base to get your new server working first.



You can ask questions if knowledge base is not clear enough for you to setup your new DO up.
I tried to set it up by your instructions. Can you please point me what am I doing wrong.

I appreciate your help :D

Screenshot 2019-03-29 at 10.27.09 PM.png Screenshot 2019-03-29 at 10.35.35 PM.png Screenshot 2019-03-29 at 10.34.55 PM.png Screenshot 2019-03-29 at 10.35.24 PM.png

p.s. thx for support. I come from dev background, and I am not so experienced with servers and domains :)


Your domain mapping should be ok, looks like your virtual host setup problem. Log a ticket with us with tmp root ssh access to it. We can check for you.