AIO is not supported on this machine!

#1
I have a VPS, OLS 1.5.10 was unable to turn on QUIC, so I try 1.6.4, I'm unable to add access.log for VHost, and I find 1 message in error.log: AIO is not supported on this machine!

How do I solve this issue?
 
#5
Thanks, I solve it by add it to vhconf.conf manually.

BTW, it's possible to roll log monthly instead of size?
Could you please instruction how fix it manually since this error AIO is not supported on this machine! still have in latest version OLS.
Thanks!
 

root

New Member
#6
Could you please instruction how fix it manually since this error AIO is not supported on this machine! still have in latest version OLS.
Thanks!
Have you tried

On centos
Code:
Download latest epel-release rpm from
http://download-ib01.fedoraproject.org/pub/epel/7/x86_64/
Install epel-release rpm:
# rpm -Uvh epel-release*rpm
Install perl-IO-AIO rpm package:
# yum install perl-IO-AIO
Or on ubuntu
Code:
Update the package index:
# sudo apt-get update
Install libio-aio-perl deb package:
# sudo apt-get install libio-aio-perl
 
Top