[ANY]IPV6 listener Can't work correctly.

#1
OpenLiteSpeed 1.4.41

2018-12-17 08:06:59.243771 NOTICE Loading LiteSpeed/1.4.41 Open ...
2018-12-17 08:06:59.243783 NOTICE Using [BoringSSL]
2018-12-17 08:06:59.246410 NOTICE [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7210
2018-12-17 08:06:59.246904 NOTICE Recovering server socket: [*:80]
2018-12-17 08:06:59.246941 NOTICE Recovering server socket: [*:443]
2018-12-17 08:06:59.246953 NOTICE Recovering server socket: [*:7080]
2018-12-17 08:06:59.247019 NOTICE chroot is disabled.
2018-12-17 08:06:59.260540 NOTICE [PID: 6805]: forked cgid: 6812
2018-12-17 08:06:59.580079 ERROR HttpListener::start(): Can't listen at address IPV6: Address already in use!
2018-12-17 08:06:59.580120 ERROR HttpServer::addListener(IPV6) failed to create new listener
2018-12-17 08:06:59.580126 ERROR [config:server:listener:IPV6] failed to start listener on address [ANY]:80!
2018-12-17 08:06:59.580139 NOTICE The maximum number of file descriptor limit is set to 30000.
2018-12-17 08:06:59.649235 NOTICE [ZConfManager] No VHosts added, do not send!
2018-12-17 08:06:59.649641 NOTICE [AutoRestarter] new child process with pid=6849 is forked!
2018-12-17 08:06:59.650610 NOTICE [child: 6849] Successfully change current user to nobody
2018-12-17 08:06:59.650682 NOTICE Child: 6849] Core dump is enabled.
2018-12-17 08:06:59.650730 NOTICE [Child: 6849] Setup swapping space...
2018-12-17 08:06:59.650821 NOTICE [Child: 6849] LiteSpeed/1.4.41 Open starts successfully!
2018-12-17 08:07:01.477577 NOTICE [Child: 6735] Shut down successfully!
2018-12-17 08:07:01.477619 NOTICE [cpanelq] stop worker processes
2018-12-17 08:07:01.477640 NOTICE [AdminPHP] stop worker processes
2018-12-17 08:07:01.477653 NOTICE [lsphp] stop worker processes
2018-12-17 08:07:01.477688 NOTICE [demoqia] stop worker processes
 
#6
I have seen before that in case , the ipv6 is not set up correctly , as can not be ping'ed from outside , it will just fail to bind with.
 
#14
first time I do see the same error as you do , but if I graceful restart it , the error is gone.

try run this

Code:
/usr/local/lsws/bin/lswsctrl stop
/usr/local/lsws/bin/lswsctrl start
 

Pong

Administrator
#16
seems there are some error "HttpListener::start(): Can't listen at address IPV6: Address already in use! "

Can you change the port number to something else like 88 instead of 80 to try?
 
Top