Cache module issue causing wordpress too slow

#1
I have server with 8GB of ram and 4 cores of processor but still sites are performing very slow after investigating that whenever i reload that site after some time it invalidates the cache and i get this
prnt.sc/qdq1gq

My site is mazahub.com and other site is funistan.ga both are using Litespeed cache for wordpress and i have even used Crawler for good performance and preload thing that i used in wp super cache but no impact at all lunchtimeresult.com same site on my server using Wp Rocket and performing outstanding than all my sites .... But every time i load my site i have to reload to hit cache. If any one can help me with this issue i will be thankful to you
 
Last edited:

Cold-Egg

Administrator
#2
Hi,

I can not visit your sites at this moment. From the screenshot you provided that means cache is not hit. You may want to check if there's any cachelookup in your .htaccess file. May I also know how did you setup your openlitespeed? e.g. from litespeed repo, or from cloud image.

Best,
Eric
 
#3
Hi,

I can not visit your sites at this moment. From the screenshot you provided that means cache is not hit. You may want to check if there's any cachelookup in your .htaccess file. May I also know how did you setup your openlitespeed? e.g. from litespeed repo, or from cloud image.

Best,
Eric
Kindly try to access now i have installed wp-rocket to mazahub.com and funistan.ga is still using ls cache ... Kindly review what is issue ... i have check .htaccess too there is no issue. I installed OLS from lcloud image .tar.gz file
 
#7
I tested with chrome, and I saw it is served by cache, you will find "x-litespeed-cache: hit" in the response header.
Did you see some others things?
 
#8
I tested with chrome, and I saw it is served by cache, you will find "x-litespeed-cache: hit" in the response header.
Did you see some others things?
Sir i have tried many times on many other sites like http://mazahub.com and https://lunchtimeresults.com with litespeed-cache for wordpress but they are not working they become too slow once they write cache miss and then after that refresh it sends header cache hit and after some time or some hours and crawler is not working as expected when i run crawler manually some of pages hit by cache but mostly fail in first attempt and page loads too slow .... Try to navigation to categories of site and other page literally they are too slow cache is not hitting ... even other site with wp rocket or other plugins are fast
 
#9
Sir here are some proofs and some times it become un responsive like server responds are a sec or 2 .... That impacts really very bad on my clients i am trying to promote OLS instead of nginx or apache because this technology is really good and it deserves appreciation. But some issues with this. I have removed this plugin from every site. Just enabled on this site to test any possible way out. https://prnt.sc/qgidfo

https://prnt.sc/qgid9y
 
#10
Right, when you see "miss", then it will goes from wordpress but not serve from cache, so that it will be very slow.
Need to find out what reason cause the content not saved to cache store when the first time served from the wordpress.
You may raise a ticket to our ticket system, and our support team may help you.
 
#11
Right, when you see "miss", then it will goes from wordpress but not serve from cache, so that it will be very slow.
Need to find out what reason cause the content not saved to cache store when the first time served from the wordpress.
You may raise a ticket to our ticket system, and our support team may help you.
Sir i am using OLS will i get support for this ? I am not using enterprise version i will feel really happy to fix this bug if possible Litespeed is very fast and it will out perform if built in caching system started working.
In near future i am thinking to make Open Source cpanel for OLS can you recommend me any language in which I should accomplish this task ?
 
Top