Cannot access admin panel

F

fotonarya

Guest
#1
After add virtual host via virtual host template, I can access https://MY-SERVER-IP:7080 . It's said The connection has timed out.

Any advice to fix this issue

Thank You

Here my error log:
2014-12-12 14:06:03.607 [NOTICE] Loading LiteSpeed/1.3.6 Open ...
2014-12-12 14:06:03.607 [NOTICE] Using [OpenSSL 1.0.1e-fips 11 Feb 2013]
2014-12-12 14:06:03.608 [NOTICE] [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7062
2014-12-12 14:06:03.608 [NOTICE] Recovering server socket: [*:80]
2014-12-12 14:06:03.608 [NOTICE] Recovering server socket: [*:7080]
2014-12-12 14:06:03.608 [NOTICE] [config] chroot is disabled.
2014-12-12 14:06:03.608 [INFO] [config] old priority: 0, new priority: 0
2014-12-12 14:06:03.608 [INFO] [config:server:basics2] For better obscurity, server version number is hidden in the response header.
2014-12-12 14:06:03.610 [NOTICE] [PID: 1299]: forked cgid: 1300
2014-12-12 14:06:03.610 [INFO] [Module: modcompress 1.1] has been initialized successfully
2014-12-12 14:06:03.610 [INFO] [Module: moddecompress 1.1] has been initialized successfully
2014-12-12 14:06:03.610 [DEBUG] [config:admin:listener:adminListener:ssl] Create SSL context with Certificate file: /usr/local/lsws/admin/conf/webadmin.crt and Key File: /usr/local/lsws/admin/conf/webadmin.key.
2014-12-12 14:06:03.612 [DEBUG] [config:admin:listener:adminListener:ssl] set ciphers to:SSLv3:TLSv1:HIGH:MEDIUM:!aNULL:!MD5:!SSLv2:!eNULL:!EDH
2014-12-12 14:06:03.614 [NOTICE] [config] The maximum number of file descriptor limit is set to 6000.
2014-12-12 14:06:03.615 [NOTICE] [config:server:rails] Cannot find ruby interpreter, Rails easy configuration is turned off
2014-12-12 14:06:03.615 [ERROR] [config:template:BETAHOST:vhost:BETAHOST] Path for vhost root is not accessible: /usr/local/lsws/BETAHOST/
2014-12-12 14:06:03.616 [NOTICE] [AutoRestarter] new child process with pid=1301 is forked!
2014-12-12 14:06:03.616 [DEBUG] [config] try to give up super user privilege!
2014-12-12 14:06:03.616 [NOTICE] [config] [child: 1301] Successfully change current user to nobody
2014-12-12 14:06:03.616 [NOTICE] [config] Child: 1301] Core dump is enabled.
2014-12-12 14:06:03.616 [NOTICE] [Child: 1301] Setup swapping space...
2014-12-12 14:06:03.616 [NOTICE] [Child: 1301] LiteSpeed/1.3.6 Open starts successfully!
 

lsmichael

Active Member
#2
Hmmm. That is odd. Let's start with the one error we can see first. What are the permissions for /usr/local/lsws/BETAHOST?

Michael
 
F

fotonarya

Guest
#3
I follow this doc for creating virtual host via virtual template.
There is no directory in /usr/local/lsws/BETAHOST created after I hit the save button. Is it normal?
 

lsmichael

Active Member
#4
This is normal. The WebAdmin cannot create this directory for you. You will have to create the directory yourself and add your website content in there.

This is almost certainly not causing the WebAdmin to time out, though.

Can you check that OpenLiteSpeed is actually running? Try accessing the default web page: YOURSERVERIP:8080

Also check to make sure the OpenLiteSpeed process is running. If it is running, there should be more in your logs. Maybe there's another error after you've tried to access the WebAdmin?

Michael
 
F

fotonarya

Guest
#5
Just try reboot the server and restart OLS
/usr/local/lsws/bin/lswsctrl start

but still cannot access WebAdmin panel nor http://my-server-ip:80/

===== error log ==========
2014-12-12 17:38:09.202 [NOTICE] Loading LiteSpeed/1.3.6 Open ...
2014-12-12 17:38:09.202 [NOTICE] Using [OpenSSL 1.0.1e-fips 11 Feb 2013]
2014-12-12 17:38:09.203 [NOTICE] [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7314
2014-12-12 17:38:09.203 [NOTICE] Recovering server socket: [*:80]
2014-12-12 17:38:09.204 [NOTICE] Recovering server socket: [*:7080]
2014-12-12 17:38:09.204 [NOTICE] [config] chroot is disabled.
2014-12-12 17:38:09.204 [INFO] [config] old priority: 0, new priority: 0
2014-12-12 17:38:09.204 [INFO] [config:server:basics2] For better obscurity, server version number is hidden in the response header.
2014-12-12 17:38:09.205 [NOTICE] [PID: 1292]: forked cgid: 1293
2014-12-12 17:38:09.205 [INFO] [Module: modcompress 1.1] has been initialized successfully
2014-12-12 17:38:09.205 [INFO] [Module: moddecompress 1.1] has been initialized successfully
2014-12-12 17:38:09.205 [DEBUG] [config:admin:listener:adminListener:ssl] Create SSL context with Certificate file: /usr/local/lsws/admin/conf/webadmin.crt and Key File: /usr/local/lsws/admin/conf/webadmin.key.
2014-12-12 17:38:09.207 [DEBUG] [config:admin:listener:adminListener:ssl] set ciphers to:SSLv3:TLSv1:HIGH:MEDIUM:!aNULL:!MD5:!SSLv2:!eNULL:!EDH
2014-12-12 17:38:09.209 [NOTICE] [config] The maximum number of file descriptor limit is set to 6000.
2014-12-12 17:38:09.210 [NOTICE] [config:server:rails] Cannot find ruby interpreter, Rails easy configuration is turned off
2014-12-12 17:38:09.210 [ERROR] [config:template:BETAHOST:vhost:BETAHOST] Path for vhost root is not accessible: /usr/local/lsws/BETAHOST/
2014-12-12 17:38:09.211 [NOTICE] [AutoRestarter] new child process with pid=1294 is forked!
2014-12-12 17:38:09.211 [DEBUG] [config] try to give up super user privilege!
2014-12-12 17:38:09.211 [NOTICE] [config] [child: 1294] Successfully change current user to nobody
2014-12-12 17:38:09.211 [NOTICE] [config] Child: 1294] Core dump is enabled.
2014-12-12 17:38:09.211 [NOTICE] [Child: 1294] Setup swapping space...
2014-12-12 17:38:09.211 [NOTICE] [Child: 1294] LiteSpeed/1.3.6 Open starts successfully!
 

lsmichael

Active Member
#6
This is all there is in the error log? There is nothing after this? That is strange.

Have you checked to see if the lshttpd process is running?

Michael
 
F

fotonarya

Guest
#7
Yes, that all in the error log

[root@server ~]# ps -ef | grep http
root 1292 1 0 17:38 ? 00:00:01 openlitespeed (lshttpd - main)
nobody 1294 1292 0 17:38 ? 00:00:06 openlitespeed (lshttpd - #01)
root 2086 2060 0 22:09 pts/0 00:00:00 grep http
[root@server ~]# netstat -an | grep 80
tcp 0 0 0.0.0.0:7080 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
udp 0 0 fe80::5400:ff:fe03:a774:123 :::*
unix 2 [ ACC ] STREAM LISTENING 8803 private/proxymap
unix 2 [ ACC ] STREAM LISTENING 8807 private/proxywrite
unix 3 [ ] STREAM CONNECTED 8809
unix 3 [ ] STREAM CONNECTED 8806
unix 3 [ ] STREAM CONNECTED 8805
unix 3 [ ] STREAM CONNECTED 8802
unix 3 [ ] STREAM CONNECTED 8801
unix 3 [ ] DGRAM 6780
[root@server ~]#
 

lsmichael

Active Member
#8
Hmmmm... It's very strange that it's timing out, but not showing any errors... Let's try turning the debug level higher. You can't get into the WebAdmin, so you're going to have to edit the /usr/local/lsws/conf/httpd_config.xml file manually. Change <debugLevel> to 9 and restart — /usr/local/lsws/bin/lswsctrl restart.

I'm going to be out of the office tomorrow, but I'll be here on Sunday. I'm also going to make sure a tech is paying attention to the thread. Sorry you're having these issues!

Oh, one last thing: the default site is IP:8080 not IP:80. You might want to check that the default site is up and running.

Cheers,

Michael
 
F

fotonarya

Guest
#9
Thank you for your concern to resolve this issue
Already change the default port to IP:80 before I cannot access to WebAbmin.
Just edit the debug level to 9, and what I have to do now?

Regards
 
F

fotonarya

Guest
#11
here after run # iptables -nL

Code:
[root@server ~]# iptables -nL
Chain INPUT (policy ACCEPT)
target  prot opt source  destination
ACCEPT  all  --  0.0.0.0/0  0.0.0.0/0  state RELATED,ESTABLISHED
ACCEPT  icmp --  0.0.0.0/0  0.0.0.0/0
ACCEPT  all  --  0.0.0.0/0  0.0.0.0/0
ACCEPT  tcp  --  0.0.0.0/0  0.0.0.0/0  state NEW tcp dpt:22
REJECT  all  --  0.0.0.0/0  0.0.0.0/0  reject-with icmp-host-prohibited
Chain FORWARD (policy ACCEPT)
target  prot opt source  destination
REJECT  all  --  0.0.0.0/0  0.0.0.0/0  reject-with icmp-host-prohibited
Chain OUTPUT (policy ACCEPT)
target  prot opt source  destination
[root@server ~]#
Code:
[root@server ~]# telnet SERVER_IP:7080
telnet: SERVER_IP:7080: Name or service not known
SERVER_IP:7080: Unknown host
[root@server ~]#
Why there is Name or service not known?

Regards
 
#12
the SERVER_IP must be replaced by a real ip, e.g. 127.0.0.1. so
# telnet 127.0.0.1:7080

do you know your server's IP ? following command can help:
#ip a

by looking at the firewall output of "iptables -nL", looks not firewall issue
 
#17
Here are the commands to just add the ports you need, if you switch to port 80 make sure to modify the commands below

Code:
sudo iptables -I INPUT -p tcp --dport 80 -j ACCEPT
sudo iptables -I INPUT -p tcp --dport 443 -j ACCEPT
sudo iptables -I INPUT -p tcp --dport 7080 -j ACCEPT
 
Top