Can't install lsphp80-pecl-imagick: nothing provides libMagickCore

#1
I have Rocky Linux 8. All packages are up to date.
I'm trying to install Imagick for OpenLiteSpeed PHP 8.0:
Code:
dnf install lsphp80-pecl-imagick
and getting the following:
Code:
Error:
 Problem: conflicting requests
  - nothing provides libMagickCore-6.Q16.so.6()(64bit) needed by lsphp80-pecl-imagick-3.4.4-1.el8.8.0.x86_64
  - nothing provides libMagickWand-6.Q16.so.6()(64bit) needed by lsphp80-pecl-imagick-3.4.4-1.el8.8.0.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
 
#2
I've installed the ImageMagick itself via:
Code:
dnf install epel-release
dnf config-manager --set-enabled powertools
dnf install ImageMagick
but I'm getting the same error when I try to install php module
 
#6
Same situation here. Though I have OLS PHP 8.1 and only lsphp80-pecl-imagick is available in the repository.

In search of a workaround, I installed ImageMagick-libs, which provided libMagickCore-6.Q16.so.7.0.0 and libMagickWand-6.Q16.so.7.0.0 in /usr/lib64/. However it did not work.
 
Top