Can't install on Fedora 31

#1
I have tried both methods of installing OpenliteSpeed 1.6.4 - via Source and via Binary. Both don't seem to work.

When I use the source method, I get this error during the make process

Code:
$ make && make install
Making all in src
make[1]: Entering directory '/home/navjot/openlitespeed-1.6.4/src'
Makefile:760: .deps/xxhash.Po: No such file or directory
make[1]: *** No rule to make target '.deps/xxhash.Po'.  Stop.
make[1]: Leaving directory '/home/navjot/openlitespeed-1.6.4/src'
make: *** [Makefile:409: all-recursive] Error 1
And when I try installing using the binary file from the downloads page I get this error after running ./install.sh



I can access the localhost:8088 just fine but I get 503 error when I try to access the admin area.

How to install on Fedora? Can someone advise?
 
#3
Code:
2019-12-02 20:59:47 URL:https://openlitespeed.org/preuse/openlitespeed-1.6.4.tgz [51106059/51106059] -> "ols.tgz" [1]
[OK] litespeed: stopped.
[OK] litespeed: pid=3736.
All binaries are updated and service is on.
The admin page is still not accessible while the server is working.
 
Top