Cold cache vs no cache TTFB

I'm observing performance results with cache plugins, that I can't explain. When running performance test on pure OpenLitespeed server (no cache enabled) here is what I get:
First Byte Start Render FCP Speed Index Last Painted Hero
First View 0.675s 1.200s 1.067s 1.655s 1.800s
Repeat View 0.445s 0.800s 0.671s 1.108s 1.200s

Let's take 0,6s TTFB as a baseline. After enabling LScache this is what I've got:
First Byte Start Render FCP Speed Index Last Painted Hero
First View 2.921s 3.300s 3.117s 3.630s 4.100s
Repeat View 0.220s 0.600s 0.485s 0.797s 1.000s

First hit is cache miss - 2,9s, second is a cache hit 0,2s. I can't explain a difference between 0,6s withouth LScache and 2,9s with LScache and cache miss. I can reproduce this everytime. There is something fundamentally wrong, but I can't tell what.



I just launched one and tested and see no difference between no cache and cache miss cases on my Chrome + developer tool.
Also tested on google page speed tool, same timing. May I know if your site is default wordpress theme and no other plugin?
Do you have all default settings on LSCache during the test?

I've asked for help on LS Cache support forum:
I've provided there details about configuration and performed test under different conditions.
I've just did another test - switched to default theme: First view is 1,6s, 2nd view (cached) 0,2s. So still way above result without LS Cache enabled. I don't think theme in this case plays significant role. I'm just testing home page, which is widget-less, almost no js.

I did one more test. I'vew disabled LS Cache, enabled WP Rocket. Results indicated that something is wrong with OLS configuration.
First view (non cached) is 2,4s, 2nd view (cached) is 0,2s. So cached and no cached results are very similar for both caching plugins.
Last edited:


New Member
I am seeing similar results. I set up /tmp as tmpfs in /etc/fstab and get slightly better results so maybe the initial delay is partly due to OLS writing out the cache files in /tmp/lshttpd/swap/.
I also had this kind of problem.
I've tried empty Wordpress, fresh installs, no plugins, or production sites.
nothing to do I have never been able to solve even by increasing the configurations related to the ram, or the size of the cache. I have really tried everything.
I will have tried so many settings, I have also tried on different virtual machines or dedicated, different kernels, with or without redis, nothing at all.:mad:

Then I ditched openlitespeed and also litespeed enterprise as it gave the same result. :unsure:

I would like to understand if the solution has been found and if so I could try again on a dedicated server.

Also because this kind of slowness on the first visit significantly affects google's crawler budget. so seo side is destructive. :sneaky:

let me know!