Customize build.sh?

deksar

New Member
#1
Hello.

I'm trying to build OpenLiteSpeed 1.7.14 on FreeBSD, getting many compilation warnings&errors, therefore I would like to ask how to customize build.sh file to exclude modules like ModSec. or GeoIP?

Is there any option to see and disable thirdparty tools/modules to prevent their installation?

Best wishes.
 

deksar

New Member
#3
Hi Cold-Egg, thanks for your return.

The forum system here blocked my message thinking it's spam, so I attached the log file here.

These are the errors I get during build. By the way, I tried to re-format my OS, install the needed packages thinking got the errors above due to lack of them, but nothing changed. Any idea, help or suggestion would be much appreciated!

Tried on both fresh installation on FreeBSD 12 and 13, same errors happen.

And in CMakeLists.txt, commented the following lines (extra modules like BoringSsl) to prevent their installation;

https://github.com/litespeedtech/openlitespeed/blob/master/CMakeLists.txt#L137

Still they installed (and gave errors)

Regards.
 

Attachments

#4
Hi, thanks for sharing, for the build issue, you might want to try a different compiler, and maybe one of them will work. The build errors are from third-party libraries, not much we can do to find a way to around it.
 
#5
Thanks for your return, Cold-Egg.

Then, how to not install modules/third-party tools like ModSecurity, BoringSSL and Luajit during ./build.sh installation? Is there any way to customize the modules to build? Is there any option to prevent their installation?

If it'd be possible to disable their installation and get a simple pure OpenLiteSpeed installation done correctly, later it's possible to compile ModSecurity through FreeBSD ports then use its .so file for OpenLiteSpeed.

Thanks.
 
Last edited:
#6
The build errors are from third-party libraries, not much we can do to find a way to around it.
Ah no, by the way, the build errors are not just from third-party libraries, because at the end of build.sh, OLS doesn't get compiled at all, please see;

make[2]: stopped in /root/openlitespeed-1.7.14/build
1 error

make[2]: stopped in /root/openlitespeed-1.7.14/build
--- src/sslpp/CMakeFiles/sslpp.dir/all ---
*** [src/sslpp/CMakeFiles/sslpp.dir/all] Error code 2

make[1]: stopped in /root/openlitespeed-1.7.14/build
--- src/thread/CMakeFiles/thread.dir/all ---
*** [src/thread/CMakeFiles/thread.dir/all] Error code 6

make[1]: stopped in /root/openlitespeed-1.7.14/build
2 errors

make[1]: stopped in /root/openlitespeed-1.7.14/build
*** [all] Error code 2

make: stopped in /root/openlitespeed-1.7.14/build
1 error

make: stopped in /root/openlitespeed-1.7.14/build
cp: build/src/openlitespeed: No such file or directory
cp: build/src/modules/modreqparser/*.so: No such file or directory
cp: build/src/modules/modinspector/*.so: No such file or directory
cp: build/src/modules/uploadprogress/*.so: No such file or directory
Start to pack files.
Building finished, please run ./install.sh for installation.
You may want to update the ols.conf to change the settings before installation.
Enjoy.


and after ./install.sh, there is no ./openlitespeed binary in /usr/local/lsws/bin at all.

Shortly, OpenLiteSpeed doesn't get compiled on both FreeBSD 12 and FreeBSD 13 - most recent production versions of FreeBSD.
 
Top