error 403 - owner of file does not match owner of vhost - strange one

Hi guys, I just run a generic yum update and after that, all my websites are denied 403
I run with Cyberpanel on Cloudlinux

I checked the log and the error is “owner of file does not match owner of vhost”
I checked the index.php and other files ownership on few websites and seems that belongs to the user in vhost
ls -l index.php returned -rw-r–r-- 1 ukcon1234 ukcon1234 index.php

After that, I run the Cyberpanel upgrade script hoping that reinstalling will correct the permissions but the problem is still present.

checked OLS server configuration on webadmin, checked all virtual hosts. everything seems well there.
But the error still persist: owner of file does not match owner of vhost, path [/home/…/public_html/index.php], access denied.

I really do not know what to check. seems like OLS do not care about vhost anymore.
Any idea what to check?
I already checked the ownership of /home files and folders. All are according to the vhosts files.
I also verified the /usr/local/lsws/vhosts/ and ownership is lsadm:nobody.
I compared folders/files ownership with another cyberpanel/ols server and are the same.

A particularity is that this problematic server runs on Cloudlinux with CageFS, other on CentOS.

Checked LSWS basic configs and compared them with the other server and everything was the same.
Now if something messed up LSWL access to the /home dir is over my knowledge and need deep investigation. Something for sure is wrong.

Any other ideas?


HIHI, just so everyone knows that the developers have openlitespeed package updated to address this issue.
New rpm and Debian packages have been pushed.
Please let us know if you encounter the same issue again.