Ghost 404 after fresh install on subfolder

#1

Attachments

lskagan

Administrator
#2
If you want ghost to run on /blog then the context URI should be /blog, try that and see if it works. If not check your error log and stderr log for more information.
 
#3
Thanks wrong screenshot i correct the URI by /blog but was the same.
And my log file doesn't show too much

Bash:
2019-12-05 16:14:48.068870 [NOTICE] [Child: 11458] Shut down successfully!
2019-12-05 16:14:48.068910 [NOTICE] [AdminPHP] stop worker processes
2019-12-05 16:14:48.068950 [NOTICE] sendKillCmdToWatchdog: 'extappkill:11505:-3:0'.
2019-12-05 16:14:48.580791 [NOTICE] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 999 gid 999 setuidmode 2.
2019-12-05 16:14:48.580832 [NOTICE] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, final uid 999 gid 999.
2019-12-05 16:14:51.056966 [INFO] Process with PID: 11519 is dead
2019-12-05 16:15:20.061031 [NOTICE] sendKillCmdToWatchdog: 'extappkill:11527:-3:0'.
2019-12-05 16:15:20.401614 [NOTICE] [11509] Cmd from child: [extappkill:11527:-3:0]
2019-12-05 16:15:20.401716 [INFO] Failed to get process [11527] start time, not running, skip killing.
2019-12-05 16:15:46.207520 [NOTICE] [!!!UPDATE!!!] new version 1.6.4.0 is available.
2019-12-05 16:15:46.207573 [NOTICE] [!!!UPDATE!!!] new version 1.6.4.0 is available.
2019-12-05 16:15:49.606181 [NOTICE] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 999 gid 999 setuidmode 2.
2019-12-05 16:15:49.606246 [NOTICE] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, final uid 999 gid 999.
2019-12-05 16:16:20.035767 [NOTICE] sendKillCmdToWatchdog: 'extappkill:11551:-3:0'.
2019-12-05 16:16:20.401002 [NOTICE] [11509] Cmd from child: [extappkill:11551:-3:0]
2019-12-05 16:16:20.401095 [INFO] Failed to get process [11551] start time, not running, skip killing.
2019-12-05 16:16:50.331363 [NOTICE] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 999 gid 999 setuidmode 2.
2019-12-05 16:16:50.331424 [NOTICE] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, final uid 999 gid 999.
2019-12-05 16:17:21.051123 [NOTICE] sendKillCmdToWatchdog: 'extappkill:11572:-3:0'.
2019-12-05 16:17:21.401025 [NOTICE] [11509] Cmd from child: [extappkill:11572:-3:0]
2019-12-05 16:17:21.401127 [INFO] Failed to get process [11572] start time, not running, skip killing.
2019-12-05 16:17:51.504186 [NOTICE] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 999 gid 999 setuidmode 2.
2019-12-05 16:17:51.504240 [NOTICE] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, final uid 999 gid 999.
2019-12-05 16:18:22.036928 [NOTICE] sendKillCmdToWatchdog: 'extappkill:11588:-3:0'.
2019-12-05 16:18:22.401100 [NOTICE] [11509] Cmd from child: [extappkill:11588:-3:0]
2019-12-05 16:18:22.401187 [INFO] Failed to get process [11588] start time, not running, skip killing.
2019-12-05 16:18:52.674748 [NOTICE] [LocalWorker::workerExec] VHost:_AdminVHost suExec check uid 999 gid 999 setuidmode 2.
2019-12-05 16:18:52.674793 [NOTICE] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, final uid 999 gid 999.
2019-12-05 16:19:23.098834 [NOTICE] sendKillCmdToWatchdog: 'extappkill:11600:-3:0'.
2019-12-05 16:19:23.401733 [NOTICE] [11509] Cmd from child: [extappkill:11600:-3:0]
2019-12-05 16:19:23.401832 [INFO] Failed to get process [11600] start time, not running, skip killing.
 
#5
Looks like i don't have permission as root user
sudo tail /usr/local/lsws/logs/stderr.log
lscgid: execve():/usr/bin/node: Permission denied
i try sudo chown -R $(whoami) /usr/bin/node
And got the same
 
#6
curl --header "Content-Type: application/json" \
> --request POST \
> --data '{"BPM":456}' \
> http://localhost:2368
<!DOCTYPE html>
<html lang="en">
<head>

<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />

<title>Ghost</title>
<meta name="HandheldFriendly" content="True" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<link rel="stylesheet" type="text/css" href="/assets/built/screen.css?v=36d5dd5c88" />

<meta name="generator" content="Ghost 3.1" />
<link rel="alternate" type="application/rss+xml" title="Ghost" href="http://localhost:2368/rss/" />

</head>
<body class="">

But OLS give 404 again
 
Top