Google Search Console - HTTPS Failure

I run a website on OLS and recently Google Search Console is reporting HTTPS failure. I have installed SSL and all content is running on HTTPS. I have also redirected all HTTP traffic to HTTPS to be sure noone browse the website without encryption.

Have anyone else experienced this and able to share what might cause it?

I have not implemented any security headers in OLS/Virtual Host. Can this be related?

(I struggle to find good documentation regards to which security headers I should add, and how to best do this in OLS).
@ronaldst I have seen this before. Check GSC whether this is related to certain URLs or the entire site. I have mostly seen this with a limited set of URLs. And usually an updated sitemap helps when you press the "fix" button
I can not figure out what is causing this error. It is still not resolved.

I have tried inspecting the SSL in different browsers and online tools, where none of them reports any errors. However, I did a SEO audit using, and it reports the following error: "Certificate registered to incorrect name".

How can that be? Any clever ideas to figure this out is appreciated.

Thank you.