[HELP] the website doesn't open, instead, it downloads the index.php file

#1
My system:
- Ubuntu 16.04
- Openlitespeed 1.5.10
- Php 7.0
- 5 wordpress website

I want to upgrade php to 7.3
After successfully upgrade php, then I create an external app in server configuration then create script handler
I deleted default php 7.0 in external app server configuration.
Suddenly, all my websites cannot be open, instead, it downloads the index.php file.

My configuration on the external app php 7.3 is:

Name lsphp73
Address uds://tmp/lshttpd/lsphp.sock
Notes Not Set
Max Connections 35
Environment PHP_LSAPI_MAX_REQUESTS=500
Initial Request Timeout (secs) 10
Retry Timeout (secs) 30
Persistent Connection Not Set
Connection Keep-Alive Timeout Not Set
Response Buffering No
Start By Server Yes (Through CGI Daemon)
Command $SERVER_ROOT/lsphp73/bin/lsphp

Any suggestions to help this situation?
 
#3
killall lsphp, and visit your site again see if it helps.

Please also share your script handler settings.
Thanks to @Cold-Egg
But, killall lsphp is not working, error lsphp no such a process

Since I'm no expert in ubuntu, I decide to reinstall dan reconfigure openlitespeed with a new version 1.6.5.

For those who got the same problem:
1. Backup first mv /usr/local/lsws /usr/local/lswsbak
2. uninstall and fresh install openlitespeed
3. test if server works fine.
4. move your data to a new lsws folder
5. reconfigured your ols
 
Top