Hi,Guys, I can Not install ionCube loder on my google cloud php version 7.4 , please help

AmanKK

New Member
#1
hi, , today i instlled a plugin a find out i need to install ioncube loder to use that plugin, afer that i have tried many artical and video nothing was perfect so i can not istall that , i am currently using 64 bit linux and 7.4. php, also i can not edit php.ini file even i have paste this code sudo chmod -R 777 /var/www/html, i need to install this coode

zend_extension = /usr/local/lsws/lsphp74/lib/php/20190902/ioncube_loader_lin_7.4.so but can`t because i can`t edit it, please help
 

Cold-Egg

Administrator
#2
Hi,

Run the following command should work.
Code:
apt-get install lsphp74-ioncube -y
killall lsphp
Please do not give 777 to the document root folder, not secure.
 

Cold-Egg

Administrator
#8
try to restart PHP by "killall lsphp", if it's not working, please create a phpinfo page and make sure the ioncube is loaded.
 
#9
try to restart PHP by "killall lsphp", if it's not working, please create a phpinfo page and make sure the ioncube is loaded.
thank you for answering it doesn't work, i contacted plugin provider he is saying i need to upgrade ioncube loader version , but i don't know how?.
can you helps me with that .

Screenshot 2022-11-15 135734.png
 
#11
,i tried but it was always showing i already have latest version 10.4.1+focal , it was not working so i upgraded my php version to 8.1 , i hope this time it will get ioncube loader 11 or above.


also is ioncube loader installing method same for php8.1 like 7.4??.
 
#12
If the theme/plugin requires a specific or latest ioncube version, then you can
1. Wait for next lsphp release
2. Compile by yourself, (but I remember we discussed that compiling manually does not work? )
I will inform our build master to update it soon. Since it's close to the US holiday, the task request may delay till next week.
 
Top