How would I create this nginx reverse proxy in OpenLiteSpeed?

#3
Update: I have been trying in vain to get Collabora set up in a reverse proxy and it keeps erroring out when I attempt to do so. As a temporary workaround, I can configure Collabora to be publically accessible via an SSL encrypted connection at port 9980 bypassing OpenLiteSpeed entirely, but I would greatly prefer a reverse proxy in OLS. Since OLS differs a bit from Apache or nginx and it does not have a straightforward way of configuring websockets in combination with a normal reverse proxy, I have hit an impasse at this point.
 
#5
Thank you. That makes sense. How would I apply this in the context of CyberPanel? I have a site already defined for office.techandtiny.com and it already creates an external app which is located at UDS://tmp/lshttpd/officet.sock.
 
#7
It does not, but I do have automated SSL (Let's Encrypt) renewals occur through their interface for the domain. So if I do this totally manually, there would no longer be panel-activated automated renewal for the SSL certs. If possible, I would prefer having my cake and eating it too.
 
#9
Bingo! I almost gave up hope when I specified URI paths of "/lool/(.*)/ws$" and "/lool/adminws" for the two web sockets proxies to 127.0.0.1:9980 that Collabora recommends in their reverse proxy guides for Apache and ngnix--no dice. In act of frustration, I instead specified the URI path as simply "/" and the address as "127.0.0.1:9980" for a single web socket proxy. That works handedly! Solved!
 
Last edited:
#10
Never mind. Editing and opening files works, but I cannot export to other file formats or print to PDF. File link:
https://cloud.techandtiny.com/index.php/s/Hso7A42tFZd3RYJ

For some reason, the OpenLiteSpeed proxy does not like the link after I select File->Print, which exports a PDF for printing:

Print as PDF link that results with a failed connection. I also tried decoding this link, though, and it still generates a 400 error: https://office.techandtiny.com/lool/https://cloud.techandtiny.com/index.php/apps/richdocuments/wopi/files/506_oc1etr6vswvh/iKIn3R3WKlUiHNx7/CVz9o8SLqNm9EqxAwfHYdWbf5p8DdNLcqMQhja6xjSyYAAX8HXmqw0DIT8mOowlo/print.pdf?WOPISrc=https://cloud.techandtiny.com/index.php/apps/richdocuments/wopi/files/506_oc1etr6vswvh&attachment=0

From what I read, Apache reverse proxy requires a "AllowEncodedSlashes On" line for this link to work. But decoded, the link still doesn't work. Thoughts?
https://help.nextcloud.com/t/export-document-as-pdf/10839
https://forum.pydio.com/t/solved-print-documents-in-collabora/778/13
 
Last edited:
#12
No. Lool, per my understanding, is the path for the websocket and the root of that path, as seen, should have nothing. I am new to Collabora, though, so I could be wrong entirely.
 
Top