image not in wp-content/upload

#1
hi, I have a wordpress site where the images are not saved in the classic structure.
They are saved in public_html / images / year / month

Which Rewrite should I use to run Webp?
Other Wordpress sites with the classic structure regularly run webp.

Obviously from the plugin they are already active and the .webp files exist in the directories.

Thank you very much
 
#3
hello, maybe I could not explain myself well.

I moved all the images into an "images" directory in the root.

probably this rewrite only works if the images are in the classic /wp-content/upload/2019/7 position.

Code:
### marker WEBP start ###
RewriteCond% {HTTP_ACCEPT} "image / webp" [or]
RewriteCond% {HTTP_USER_AGENT} "Page Speed"
RewriteRule. * - [E = Cache-Control: vary =% {ENV: LSCACHE_VARY_VALUE} + webp]
### marker WEBP end ###
Here you can see how I did to move the wordpress image directory.
https://www.webnots.com/change-default-media-upload-folder-wordpress/

Thank you all
 
#4
Hi,

You mean , you have changed the default upload path , and webp doesn't work in that case ?

If you changed it properly it should work.

Please enable LSCWP debug log , and see what logs says.

with each webp replacement , even failed, it should log a line to indicate the resons.

Best regards,
 
Top