ipv6 listeners stop working

#1
Hi guys,

I'm running OLS with Directadmin and when there is a restart of OLS very often the ipv6 listeners don't 'start'. In the logs it says they are busy, but they are not.
Most of the time a manual restart solves the issue, but sometimes it needs a stop and start action to get it reachable again. It seems like the ipv6 connections stay busy during the restart.
It's quite an issue since I don't always know when OLS has been restarted and for a lot of visitors the sites become unreachable.

I found out I'm not the only one:
http://forum.directadmin.com/showthread.php?t=58574&p=302353#post302353

Thanks in advance for your suggestions.
 
#3
Same issue for me (already included in the above thread at the directadmin forum).
But let me expand with some extra info:

/usr/local/lsws/bin/openlitespeed -v
LiteSpeed/1.6.1 Open
module versions:
modgzip 1.1
cache 1.61
modinspector 1.1
uploadprogress LSIAPI_VERSION_STRING
mod_security 1.1
(built: Tue Sep 17 21:14:16 UTC 2019)
module versions:
modgzip 1.1
cache 1.61
modinspector 1.1
uploadprogress LSIAPI_VERSION_STRING
mod_security 1.1
 
#4
1, If you fully stop the service and start it, it is always busy, it may be due to the port is still occupied or mistake in the conf file.
2, If it is not always occur, just happen sometimes, it may be some service is using the port, please try to find the service and kill it first.
 
#5
1, If you fully stop the service and start it, it is always busy, it may be due to the port is still occupied or mistake in the conf file.
2, If it is not always occur, just happen sometimes, it may be some service is using the port, please try to find the service and kill it first.
In my case a full stop and start always solves the problem. It seems like a (graceful) restart causes the issue. So after nightly stats updates, but also after restarting it for htaccess updates.
Service that's using it is OLS itself as far as I could find back in de firewall stats.
 
#7
Yes, I can confirm the same.
Stopping the service, and then starting again always works.

When watching the service from the LiteSpeed WebAdmin Console I can click the top-right green 'Graceful Restart' button, and if it's listening to the IPv6 ports before, then every time it fails to listen after the restart, but also if it failed to listen to the IPv6 ports before, then every time after pressing the restart button the service will be listening to the IPv6 ports correctly after.
 
#8
Any update on this issue? Is there a configuration we can change to prevent this?
For now I disabled ipv6 for web so people will fallback top their ipv4, but that's a work around that is not really the way it should be and definitely not future proof.
 
Top