Nextcloud & Owncloud Installation issues with MySQL?

Discussion in 'Linux Support: Debian, Ubuntu, SolusOS etc' started by BGV, Jul 22, 2016.

  1. BGV

    BGV New Member

    Hello all. I'm having issues with getting Nextcloud & Owncloud to install with the latest OpenLiteSpeed 1.4.19. I have the repo distro installed and installed OLS along with the php modules. It seems for some reason the php pdo mysql module is having issues when connecting to local mysql. I know the mysql server I am running works fine as well as the php and installation of OLS (have multiple other php sites installed like codeigniter, laravel, wordpress and a few others). Things run perfectly but for some reason neither NextCloud nor Owncloud can get installed via MySQL. SQLite installation works, but is not what I am looking to do though. Any help or suggestions would be greatly appreciated.

    Error log from owncloud:
    "PHP","message":"PHP Startup: Unable to load dynamic library '\/usr\/local\/lsws\/lsphp70\/lib\/php\/20151012\/php_pdo_mysql.dll' - \/usr\/local\/lsws\/lsphp70\/lib\/php\/20151012\/php_pdo_mysql.dll: cannot open shared object file: No such file or directory at Unknown#0","level":3,"time":"2016-07-22T03:58:55+00:00","method":"POST","url":"\/oc\/index.php","user":"--"}

    The web configuration page gave this error:
    [2002] SQLSTATE[HY000] [2002] Can't connect to local MySQL

    Thanks again for any help.
  2. lsfoo

    lsfoo Administrator

    Hi Brian,

    Sorry for such a late response, your post(s - there was one from a couple weeks ago, I hope I selected approve and not delete) got caught in the moderation queue. Just wanted you to know that we'll look into it.


    EDIT: Our primary dev says that this may take a little time to figure it out.

    Do you still need help regarding vhost templates?
    Last edited: Jul 27, 2016
  3. BGV

    BGV New Member

    Some help regarding the vhost templates would be greatly appreciate. Specifically, where in the process of setting up a new vhost is it possible to select which vhost template should be used?

    I am wondering if the issue with NextCloud & OwnCloud has to do specifically with PHP7. It seems I am having difficult installing a lot of different php scripts/apps and that is the only common issue I can think of. The issue specifically (as mentioned in my original post) is when trying to connect to mysql databases.
  4. lsfoo

    lsfoo Administrator

    Hi Brian,

    This wiki may be useful.

    Essentially, you select the vhost template first, creating a member vhost off of the template. The member vhost can then be converted into a regular vhost if that's what you prefer.

    Have you tried them with 5.6 to see if they work fine? If so, that could be it.
  5. BGV

    BGV New Member

    Thank you that worked.

    Took some configuring. Maybe a note on that wiki page would be nice that says "Change Example under Listeners to not be Domains: *" because for a while I was trying to figure out why the domain kept going to the root/Example vhroot.

    Also, most Americans wouldn't know what "Instantiate" would mean to create it as a standalone virtual host.

    Thanks again for your help. Side note, I have sent multiple messages to Contact Us about requesting to get my username changed. How do I go about doing that?
  6. lsfoo

    lsfoo Administrator

    Hi Brian,

    Noted. Will update the wiki accordingly, thanks!

    What would you like to change it to? You can message here or send me a pm, I'll see what I can do.

  7. lsfoo

    lsfoo Administrator


    Regarding the nextcloud/owncloud issue, how did you install the php extension?

    One thought is that if the file does exist, then the .dll extension may be causing problems. Do you know if you can get a .so version?
  8. BGV

    BGV New Member

    I installed LSPHP by the apt debian repo

    apt-get install lsphp70 lsphp70-*

    everything shows up fine on my phpinfo page (even mysql/mysqli/mysqlnd) but it still can not resolve mysql databases.

    I did notice that after doing the apt-get install, I had to manually symlink the /usr/local/lsws/lsphp70/bin/lsphp to the /usr/local/lsws/fcgi-bin/lsphp

    im going off the top of my regarding the location above. correct me if i am wrong.
  9. lsfoo

    lsfoo Administrator

    Regarding the symlink, this wiki may be useful.

    You can skip the install part as you're installing via repos, but the external app and script handler configuration are what you're looking for.

    I think we may have figured something out. We tested your command, and found this:
    From your error log, it looks like it's trying to find php_pdo_mysql.dll. That's the incorrect file.

    In your php.ini, if you used a generic template, you should be able to search for "pdo_mysql" and find:
    Change that to:
    Note the removal of the semicolon at the beginning of the line.

    If your php.ini is blank, just insert the new line.

    After the change, restart the server. It should now be able to load the .so.

Share This Page