no lsphp socks in /tmp/lshttpd

#1
I configure LiteSpeed SAPI App lsphp for template (it works on litespeed)

Name $VH_NAME_lsphp
Address uds://tmp/lshttpd/$VH_NAME_lsphp.sock
Environment PHP_INI_SCAN_DIR=$VH_ROOT/$VH_DOMAIN/php/conf.d

but then
- there is no lsphp socks in /tmp/lshttpd
- Environment variable interpolate to $VH_ROOT/$VH_DOMAIN/php/conf.d

so variables are not working, why?
php works but I have no idea how?
 
#8
I removed the lsphp template since we added extuser/extGroup for lsphp and also VHost can inherit the server lsphp with ita own user/group.
So you may use the SERVER level defined lsphp directly.
About the $... variables, I need to check the code if we support them.
 
#10
I removed the lsphp template since we added extuser/extGroup for lsphp and also VHost can inherit the server lsphp with ita own user/group.
So you may use the SERVER level defined lsphp directly.
About the $... variables, I need to check the code if we support them.
I dont know what you mean.
I thought that
ExtApp Set UID Mode = DocRoot UID
set lsphp to run as specific user/group

with OpenLiteSpeed 1.4.46
still see this option
 
Top