"No request delivery notification has been received from LSAPI application, possible dead lock."

Pyon

New Member
#1
Hello guys, I've been having a problem with one of the WordPress sites that I'm running.

I've been continually getting the following notice for the past several weeks and could not for the life of me figure out what is wrong:

"No request delivery notification has been received from LSAPI application, possible dead lock."

I've tried googling this issue, but it seems that there isn't very much information about this. This notice is the only one that seems to pop up as my server's CPU load becomes unnecessarily high.

Have you guys had this issue before? How did you resolve this issue?
 

Pyon

New Member
#3
Thanks for responding.

This message is from the openlitespeed admin console of the website I am hosting. I've attached a screenshot showing the notice.

As for the steps to reproduce the error, I'm not entirely sure how to reproduce it exactly, but I'm hosting a WordPress site on PHP 7.3.6.
 

Attachments

Pong

Administrator
#4
the message itself just means php doesn't receive a response. Please try to see which URL trigger such error.
Once you have the URL, log a ticket with us with tmp root accesss to your server for us to take a look.
 
#5
Did you find a solution for this?

I am experiencing the same problem on a WordPress site I recently moved to a VPS running OpenLiteSpeed.

This error can be reproduced when saving changes to a file in the built-in theme and plugin editor in WordPress. Tailing the error logs shows multiple entries of "No request delivery notification has been received from LSAPI application, possible dead lock" and the webserver freezes not accepting any other requests while this is going on.

I am using newest stable version and PHP 7.3.
 
#6
I think you are using DA+OLS+CL, if yes, please update the
`httpdworkers 2`, lsphp maxConnection to 10, ENV CHILDREN to 5, or ask DA team.
Thanks.
 
#7
I think you are using DA+OLS+CL, if yes, please update the
`httpdworkers 2`, lsphp maxConnection to 10, ENV CHILDREN to 5, or ask DA team.
Thanks.
I am not using DirectAdmin, if that is what "DA" refers to. I'm on a CentOS 7 minimal with MariaDB and OpenLiteSpeed + PHP 7.3. I am using 2 workers on this VPS and have 2 workers. I've probably set max connections and children too high, however, I doubt this is related to that as I'm far from maxed out on (any) resources.
 
#8
OK. Sorry for my question, because I got some tickets as I just mentioned and they are the same result as your issue.
So, yes, do some tuning of the php children and max connection.
Please let us know if it is fixed or not.
 
#9
I've tested it and it does not resolve the error/lockup. Logs are showing multiple entries of:
No request delivery notification has been received from LSAPI application, possible dead lock

However, this might not be a OpenLiteSpeed problem for all I know. It could be a PHP configuration issue too.
I will run wp-debug and see if I can get any wiser.
 
Top