OLS and DokuWiki RewriteRules

Discussion in 'OpenLiteSpeed Bug Reports' started by enthess, Sep 16, 2016.

  1. enthess

    enthess Member


    I am setting up a DokuWiki and ofcourse i am using OLS as webserver for this purpose.

    I have a problem displaying images with .htaccess RewriteRules.
    The images are displaying if i am not using pretty Urls or Rewrite at all.

    Without further testing i assume the other 2 rules are not working either.
    RewriteRule ^_media/(.*) lib/exe/fetch.php?media=$1 [QSA,L]
    RewriteRule ^_detail/(.*) lib/exe/detail.php?media=$1 [QSA,L]
    RewriteRule ^_export/([^/]+)/(.*) doku.php?do=export_$1&id=$2 [QSA,L]

    tldr; lib/exe/fetch.php?media=... works, displays images.
    _media/ rule, no image .

    There is no documentation or anything about OLS and DokuWiki, so i guess someone hasnt experienced this issue or havent tried OLS and DokuWiki.

    but since this should work with good ol apache .htaccess file, then it should work with OLS too...

    I have no idea how to solve this... :/
  2. enthess

    enthess Member

  3. lsfoo

    lsfoo Administrator

    Good to know that you solved it :)

    Is it still working as expected?
  4. enthess

    enthess Member

    Yupp no problem yet so far! :)
    I tried the ols1clk aswell, it worked verywell , except the adminpassword for the web didnt work and i had to reset it with the adm_pass.sh script.
    Although i think ols1clk should be renamed ols1cmd ... since its not clickable :)
  5. lsfoo

    lsfoo Administrator

    Glad to hear it!

    Could you paste the command you ran for ols1clk? Obviously omitting the password. If your password had any special characters, please mention it though, cause that may have caused the issue.

    We'll think on the name, but it'd be difficult to change things now :D
  6. enthess

    enthess Member

    I think i just ran the command ./ols1clk -a <mypassword> --lsphp 70 , that was it.
    the installation went fine, but when i was accessing admin-interface the admin:myPassword was not working... i ran adm_pass and i assigned same password again, and it worked.

Share This Page