Openlitespeed downloading PHP Files

Hi, all i just installed openlitespeed on Centos 7

1) rpm -ivh
2) yum install openlitespeed
3) yum install lsphp56-* --skip-broken
4) ln -sf /usr/local/lsws/lsphp56/bin/lsphp /usr/local/lsws/fcgi-bin/lsphp5
5) /usr/local/lsws/bin/lswsctrl start

all installation works just fine, but when i try to see phpinfo from DEFAULT http://myip/phpinfo.php openlitespeed download file.

Any suggestion please?


Hi skintekx,

If you installed OpenLiteSpeed with all the default configurations, the server will by default listen to an alternate port, port 8088. Since this is a non-standard port, you will have to include the port when you try to access the page of that Virtual Host.

In the default case, it would be http://myip:8088/phpinfo.php.

Please let me know if this didn't work, and don't hesitate to ask questions, we're always willing to help!

no i installed on port 80, and is downloading files, after some experiences with free centos panels i move back home, and i will continue with openlitespeed, i have centos 7 and i will fresh install soon and i will write if something change.Thanks for great support and help.


Hi skintekx,

Thanks for the reply!

If it is still downloading, please check the error log. If OpenLiteSpeed is installed in the default directory, it should be located at /usr/local/lsws/logs/error.log, otherwise it will be at wherever the prefix you installed it at ./logs/error.log.

Post any error messages that you may see (it will have ERROR within the line).

Another option is trying curl.
Try the following command:
curl -I http://localhost/phpinfo.php

The output should look similar to:
HTTP/1.1 200 OK
x-powered-by: PHP/5.6.6
content-type: text/html; charset=UTF-8
date: Tue, 28 Apr 2015 20:36:58 GMT
server: LiteSpeed

If it doesn't look something like that, there may have been some issues when you linked the new php version.
hi thanks for your great support, i reinstalled openlitespeed and now a have error 403 on phpinfo.php here is a print screen with error logs in admincp

[root@localhost ~]# curl -I http://localhost/phpinfo.php
HTTP/1.1 403 Forbidden
date: Sat, 02 May 2015 17:12:33 GMT
server: LiteSpeed


Hi skintekx,

From the first error line, it looks like something about your PHP/server installation is incorrect.

Possible problems:
1. The file does not exist.
2. There is a permission issue. I.E. php was installed as root and you tried to run the server as non-root user, so the server didn't have the permissions to use it.
3. If your OS is on a 64 bit system, there may be an issue with using a 32 bit binary without the compatible libraries installed.

Let me know if any of these end up fixing your issue, or if none of them fix your issue.

i can't test your solutions guys cause i allready reinstalled centos 7 ....
But, thanks for your help, i just followed the Setup Guide provided by Slavik compiled php 5.6.6 and as database server Percona and my website rocks.;)


Well, whatever works right?

Thanks for being so dedicated, let us know if you have any more problems!