Operation Timed Out Error

My name is Vishal. I am getting a cURL timeout error. You can see the error in this image: https://pasteboard.co/Kdz3Rhh.png

I am using Google Cloud Hosting + Litespeed and I just want to know how I can fix this?

Few extra details - I am using Wordpress's latest version with Cloudflare activated.


Not so sure since it only shows facebook-for-wooconerce plugin has such an issue on your site. Do you have any firewall or security plugins? Maybe you can try to turn those off temporarily and see how it goes.
This didn't help.
I really need to fix this as woocommerce.json API is very much needed for functions to work properly. IDK the root cause of this problem. But can someone plz help?

I recently disabled all plugins except woocommerce and above mentioned 3 plugins. And I even switched my theme to Storefront and temporarily disabled Cloudflare but it didn't solve the problem. I even updated my PHP to latest PHP v8.


I want to help, but no clue. Could you reproduce the issue by installing default Woocommerce on the fresh OpenLiteSpeed WordPress image? If so, let me know, I will take a deeper look.
Thank You!
Even IDK how to solve this?
Here is what I tried:
I created a new Litespeed installation and with the help of the duplicator plugin, I cloned my website on a different Google Cloud server. Then I purchased a test domain from Freenom and linked it to this website and Installed Cloudflare.

Every setting on Cloudflare was exactly the same that I used on my previous site. Just this time the Cloudflare nameservers and domain registrar were different.

After waiting for few hours, I noticed that I am not getting a single error on my cloned website. And, this whole thing is super confusing, and it's very difficult to understand the root cause of this problem.

SO, maybe there is a special code/function on my previous website that is only executed when my previous domain is used. I am just guessing.
I am tired solving this error. From days I am trying to fix this. And this happening with only my previous domain.

I upgraded PHP, Litespeed, and Curl versions but nothing helped. And even I cloned my website again and this time I linked my previous domain and got the same error on this installation.

If you know someone who can help then please forward this forum to them.
I just wanted to add few more things.
Recently with cURL, Ajax error started to appear. Now, I can't duplicate products without a 524 error. Like 524 error is pretty common throughout the dashboard. If it's served from the Cloudflare cache then it works perfectly but when the server request is made then it is slow and it results in a timeout. Such timeouts occur while deleting plugins, duplicating, or creating products. I things it's bcoz of the Woocommerce.Json API not loading.

WordPress is very time-consuming at least for me. I wish woocommerce was a managed solution like Shopify which never consumes such time.


I tried a fresh installation this time with no-cloning and linked my domain. Installed theme, jetpack, woocommerce and got the same curl 28 error. I switched the theme to just confirm if it's a theme issue but received the same error. I did all from my side.

Here my system details -
cURL version - 7.78.0 OpenSSL/1.1.1f
PHP version - 8.0.8 (Supports 64bit values)

On a new fresh installation, I tested without linking my domain. And I used the default PHP & cURL version but got the same error. Now it's confirmed that it's an openlitespeed problem.
Last edited:



I've tried to install 4 plugins and set up woocommerce with example products and storefront theme, still, no error shows in Query Monitor.

Please help to narrow down on which button you clicked to trigger the API or any other plugin you have installed?