Page generated by LiteSpeed Cache missing

#1
So i have installed OpenLiteSpeed, added like 8 websites, all good. One time i decided to add Litespeed Cache for wordpress. Just default setting. On all my websites i have this message on bottom of the source:

<!-- Page optimized by LiteSpeed Cache @2019-11-20 21:18:18 -->
<!-- Page generated by LiteSpeed Cache 2.9.9.1 on 2019-11-20 23:18:18 -->

BUT on one of them i have only
<!-- Page optimized by LiteSpeed Cache @2019-11-20 21:31:10 -->

the other line is missing completely ... I am curious, why is this happening? I have the exact same settings for all my websites, all are displaying the same 2 lines, but one doesn't ...
The settings in virtual hosts are 100% the same, the settings in WP plugin are the same, some plugins may (slightly) differ from one website to another, but not a single one referred to cache. Do anyone have any idea why is this behaviour, how can i fix it and if have an impact on the website that the line is missing.

Best regards,
edutz.
 
#2
Hi,

Could you please check the HTTP Header on the site that shows 1 line ? see if you got `x-litespeed-cache: hit/miss` header?

Best regards,
 
#4
Hi,

Check if both sites are login user , the second string should only visible to login admin.


but you seems to have other issue that is weird both of your site no showing x-litespeed-cache hit/miss header.

could you please check in OLS server setting, modules , cache module is enabled ? and also the cachedata dir is writable
 
#5
yeah you're right, i was messing with the cache module and forgot about it, reactivated it and not it sais miss 1st try and hit second try, so working as normal.
http://prntscr.com/q05b24 for the one with one line
http://prntscr.com/q05bye for the one with both lines....

Doesn't matter if i'm logged in or not, in both situations on one website i have only one line, on the other ones 2 lines. Checked on other websites (not mine) and confirmed they have also both line in source ... so i'm feeling like i'm missing something even though in the header it says hit....
 
#6
Hi,

In LSCWP code

Code:
        if ( $running_info_showing ) {
            // Give one more break to avoid ff crash
            if ( ! defined( 'LSCACHE_IS_ESI' ) ) {
                $this->footer_comment .= "\n" ;
            }
            $cache_support = 'supported' ;
            if ( defined( 'LITESPEED_ON' ) ) {
                $cache_support = LiteSpeed_Cache_Control::is_cacheable() ? 'generated' : 'uncached' ;
            }
            $this->footer_comment .= sprintf(
                '<!-- %1$s %2$s by LiteSpeed Cache %4$s on %3$s -->',
                defined( 'LSCACHE_IS_ESI' ) ? 'Block' : 'Page',
                $cache_support,
                date( 'Y-m-d H:i:s', time() + LITESPEED_TIME_OFFSET ),
                self::PLUGIN_VERSION
            ) ;
        }
You will see all the conditions.

true on LITESPEED_IS_HTML or LSCACHE_IS_ESI

LSCACHE_ESI_SILENCE not defined

not is_rest call or is_ajax call

not override by litespeed_comment filter

defined LITESPEED_ON on

check is_cacheable is true


Are they same site ? there may be some sub-condition does meet the requirement.
 
#7
They are the exact same sites, but with a different wordpress theme. In the wordpress plugin LSCache all the options are 100% the same. Just checked again in virtual hosts and the settings are 100% identical. IDK what i'm missing.

EDIT: checked on all websites, this issue is visible only on the websites with the same theme like the one i was complaining about.
 
Last edited:
#10
Well, the problem we figured this far is that something in the theme breaks LSCWP .... i also tried another themes one of which completely gives 503 error if activated. I'm not asking for a personal debug but at least some guidance if possible. I have all the logs, but they are too thick to understand (in my perspective) ...
 
Top