Question about the correctness of the gzip configuration

It seems that the gzip is configuredcorrectly.
Serwer Debian, OpenLiteSpeed 1.5 (last updated), lsphp-72, lsmcd (on).
The main web application is MOODLE.

Server Configuration > Tuning

GZIP Compression
Enable Compression Yes
Enable Dynamic Compression Yes
Compression Level (Dynamic Content) 6
Compressible Types text/*, application/x-javascript, application/xml, application/javascript, image/svg+xml, application/rss+xml, text/xml
Auto Update Static File Yes
Static GZIP Cache Directory Not Set
Compression Level (Static File) 6
Max Static File Size (bytes) 10M
Min Static File Size (bytes) 300

Brotli Compression
Enable Brotli Compression Yes
Virtual Host > Basic
Max Keep-Alive Requests Not Set
Smart Keep-Alive Yes

Virtual Host > General

Enable Compression Yes
As I check on chrome Network -> Headers
Request Headers
:method: GET
:path: /
:scheme: https
accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3
accept-encoding: gzip, deflate, br
accept-language: pl-PL,pl;q=0.9,en-US;q=0.8,en;q=0.7
cache-control: max-age=0
cookie: EU_COOKIE_LAW_CONSENT=true; MoodleSession=pq6md2g66j0825h1to67ju3mb2
upgrade-insecure-requests: 1
user-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36
As I check on
Quick server response time
Compression not enabled
Browser caching enabled
Keep-alive not enabled
Minimal redirects
Analogously at
GZIP Is Not Enabled
Original Size: 44.5 KB
GZIP Size(compressed): 20 B
Compression %: 99.96% could have been compressed
More Information
HTTP Status: 200 OK
Request Time: 1425 ms
Compression Time: 0 s
Content Type: text/html
Server: LiteSpeed
Similarly, the Keep-alive tests show not enabled

I wonder if I made a configuration error somewhere, or maybe I have not yet switched to the way of thinking about the OpenLiteSpeed configuration.
I am asking for suggestions, possibly for clarifying the source of the problem.

Mariusz Pulkowski
thank you for your answer. Maybe I was not very precise in my speech.
I checked my site at Indicates whether compression is enabled.
I have only lsphp and OLS installed on my server.

I have gzip entries on phpinfo.
Phar: PHP Archive support enabled
Phar EXT version 2.0.2
Phar API version 1.1.1
SVN revision $Id: f1155e62742ca367e521a3e412667d8ee34eead9 $
Phar-based phar archives enabled
Tar-based phar archives enabled
ZIP-based phar archives enabled
gzip compression enabled
bzip2 compression disabled (install pecl/bz2)
Native OpenSSL support enabled
Phar based on pear/PHP_Archive, original concept by Davey Shafik.
Phar fully realized by Gregory Beaver and Marcus Boerger.
Portions of tar implementation Copyright (c) 2003-2009 Tim Kientzle.
Directive Local Value Master Value
phar.cache_list no value no value
phar.readonly On On
phar.require_hash On On
PHP Variables
$ _SERVER ['HTTP_ACCEPT_ENCODING'] gzip, deflate, br
Mariusz Pulkowski


check header through Chrome developer tool.
It shows "Aapche"
and "content-encoding: gzip" no problem with apache at the moment.

Is your server ip:

Request URL:
Request Method: GET
Status Code: 200
Remote Address:
Referrer Policy: no-referrer-when-downgrade
accept-ranges: bytes
cache-control: max-age=300, public
content-encoding: gzip
content-length: 19412
content-type: text/html; charset=UTF-8
date: Wed, 01 May 2019 15:08:31 GMT
etag: "14548-5536ed7602d57-gzip"
last-modified: Mon, 03 Jul 2017 19:33:28 GMT
server: Apache
status: 200
strict-transport-security: max-age=15555555; includeSubDomains; preload
vary: Accept-Encoding
x-frame-options: SAMEORIGIN


Thank you for your response.
in my first statement I gave a fragment of the description of the connection with Chrome, and in it the
domain address:

Two different addresses:
these are just the web addresses of public testers that I used. I also gave the results of their tests.
I wonder where this difference between Chrome and test addresses will come from.

As you can see, English is not my strong point.
Mariusz Pulkowski