recaptcha dont work

#1
Hello

I have problem with recaptcha
I use openlitespeed 1.5.2 with directadmin control panel

Code:
LiteSpeed/1.5.2 Open
    module versions:
    modpagespeed 2.2-1.11.33.4
    cache 1.61
    modinspector 1.1
    uploadprogress LSIAPI_VERSION_STRING
    mod_security 1.1
 (built: Fri Jun 21 20:33:31 UTC 2019)
    module versions:
    modpagespeed 2.2-1.11.33.4
    cache 1.61
    modinspector 1.1
    uploadprogress LSIAPI_VERSION_STRING
    mod_security 1.1
I change in file httpd-lsrecaptcha.conf

Code:
lsrecaptcha  {
  enabled                 1
  siteKey                 thisourkey
  secretKey               thisoursecret
  type                    2
  maxTries                3
  allowedRobotHits        3

  botWhiteList  {
# google.com
  }
  regConnLimit            15000
  sslConnLimit            10000
}
Put in .htaccess file

Code:
RewriteEngine On
RewriteCond %{HTTP_USER_AGENT} ^Mozilla.*
RewriteRule .* - [E=verifycaptcha]
and restart litespeed server
but captcha dont work
Also tried to make these settings in the user's personal virtualhost, also does not work.
 

lsfoo

Administrator
#2
Ultrasparc,

If you set the reg conn limit and ssl conn limit both to 1, then restart the server, will it work?

Kevin
 
#7
When i change
regConnLimit to 1
and
sslConnLimit to 1
Then Captcha work fine, but work for all sites.
Rewrite rule with [E=verifycaptcha] don't work when change regConnLimit and sslConnLimit to 1000
 
#8
Apologies for the late reply.

To clarify, these are two ways to toggle reCAPTCHA.

The regConnLimit and sslConnLimit check the number of concurrent visitors to each VHost on a single worker process. Upon crossing the threshold, new visitors should redirect to reCAPTCHA.

The rewrite rule is a second toggle. When OLS sees the rewrite rule, it checks if the visitor has already completed the reCAPTCHA. If not, it should redirect.

Given that reCAPTCHA worked fine with the conn limit, it sounds like it is specifically an issue with the rewrite rule toggle.

Can you confirm that the rewrite rule properly matches the page you are visiting? If so, I'd like to see the debug log for a request that should have redirected to reCAPTCHA. You can use the conn limit 1000 + rewrite rule combination.
 
Top