[Solved] Cannot log into Openlitespeed web admin after script upgrade


New Member
I have been using ols-docker-env on Ubuntu 18.04 since February. The docker env file says the version is 1.6.5.build.

Now I made a huge mistake. I wanted to upgrade to a more recent version of Openlitespeed.
Without thinking any further I run the upgrade script from outside the docker container as a normal user (just like I do when starting the docker compose), not root, with command bash bin/webadmin.sh --upgrade, just as the ols-docker-env github readme page tells one to. Mind you, now I have found out (after the fact) that the bin/webadmin.sh script has been improved in github. But it is late for that now.

After the upgrade I cannot log in to the Openlitespeed web admin panel anymore.
It tells me my credentials are incorrect, though I am certain of my credentials being correct.

The site which the server runs works, but I cannot do anything to it with the Openlitespeed web admin – and there are improvements waiting.

I need to get in to the Openlitespeed web admin.


I got it sorted out by reading the script. The upgrade script can be run from outside the docker container, but essentially it is just a wrapper for another shell script which is run inside the container. All possible error messages will be shown only inside the container.

It turned out that the upgrade script had deleted my admin password. But inside the docker container in directory /usr/local/lsws/admin/misc/ there is a shell script admpass.sh with which the password can be reset. I ran it and updated the password, and now it works again.

I'll leave this short story here just in case anyone else runs into this problem.
Last edited: