[STDERR] Reached max children process limit: please increase LSAPI_CHILDREN.

#1
Hello,

I have this errors in stderr.log
Code:
[STDERR] [UID:1006][1041] Reached max children process limit: 21, extra: 7, current: 28, busy: 28, please increase LSAPI_CHILDREN.
First time I have this error when there was have limit to 10 connections.

After that I increased limit connection to 15. But after few hours still have that error but for 15 connections.

Ok.. I increased limit connection to 20. And now I have errors that I need more connections. Looks like I can increase connections to infinity and always will be have this errors demanding more and more connections

I checked my php process, usually I have 4 php process. Never seen more then 4.

I host only one site with low traffic. My VM is 2CPU with 8GB RAM on google cloud.

How I can fix this problem? Thanks.

I have OLS 1.6.20. Ubuntu 20. Cyberpanel 2.0.3.
 

Cold-Egg

Administrator
#2
May I know which CMS it is? Do you have any cache enabled? About low traffic, do you know how many concurrent connections?
 
#5
Just cant understand - why when I was have 10 limit connections, there were always no more than 3 extra connections. When I increased to 15, there were no more than 5 extra connection. When I increased to 21 limit connections, I have 7 extra connections, with total 28 connections.

Why when I was have 10 limit connections, wasn't there total 28 connections? In other words then more I have limit connections, then more extra connections I needed...
 
Last edited:

Cold-Egg

Administrator
#7
What did you see with the following command when it shows extra connections? You can keep monitoring it and check if this has anything to do with limit settings?
Code:
ps aux | grep lsphp | grep -v grep
 
Top