The lsphp 7.3 version and the behavior of CMS MOODLE

#1
He,
I have properly configured php, it seems so.
The minimum CMS MOODLE requirements for php are v.7.1.
The MOODLE system works correctly, PHP Version 7.3.3-2 + stretch in reports.
There are individual modules that behave strangely. Launching Cron displays the sequence of errors is the same each time it is started. Browsing the MOODLE forums, I found solutions to the problem by switching from php7.0 to php7.1 and above.

The system has the option of choosing lsphp7.1, lsphp7.2 and lsphp7.3. In each part of the common configuration is "uds: //tmp/lshttpd/lsphp.sock".
For lsphp 'Comannd', the value is: 'fcgi-bin / lsphp73'.
In 'fcgi-bin' there is a link: 'lsphp73 -> /usr/local/lsws/lsphp73/bin/lsphp'.

Like everything is OK, the MOODLE platform is working, but errors suggest a wrong version of php7.0.
Although the environment indicates php7.3, the individual functions invoked by 'Cron' indicate that the minimum version of php7.1 is not met.
Is it possible that socket address 'uds: //tmp/lshttpd/lsphp.sock' may be the source of problems?
Have you come across a similar case?

Regards
Mariusz Pulkowski
 
#2
He,
For the MOODLE system, there is a second method for calling Cron from the address https: //elearning......./admin/cron.php. For this variant, LSWS invocation works almost correctly. On some calls, the cron's execution time exceeds 200 seconds. The Debian system calls Cron every 1 minute. LSWS stops when it exceeds 200 seconds and queuing processes. This way the WWW server stopped twice.
I checked for errors that suggested changing the php version from 7.0 to a higher one. The system reports version lsphp7.3.
Discussion of one of the reported errors on the MOODLE forum.
https://moodle.org/mod/forum/discuss.php?d=386554

Anyone have any ideas on how to solve this problem?

Regards,
Mariusz Pulkowski
 
#4
My phpinfo is:

PHP Version 7.3.3-2+stretch

SystemLinux elearning-dwa 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64Build DateMar 26 2019 13:34:10Configure Command'./configure' '--prefix=/usr/local/lsws/lsphp73' '--disable-cgi' '--enable-cli' '--enable-phpdbg=no' '--with-litespeed' '--with-config-file-path=/usr/local/lsws/lsphp73/etc/php/7.3/litespeed/' '--with-config-file-scan-dir=/usr/local/lsws/lsphp73/etc/php/7.3/mods-available/' '--build=x86_64-linux-gnu' '--host=x86_64-linux-gnu' '--libdir=${prefix}/lib/php' '--libexecdir=${prefix}/lib/php' '--datadir=${prefix}/share/php/7.3' '--program-suffix=7.3' '--disable-all' '--disable-debug' '--disable-rpath' '--disable-static' '--with-pic' '--with-layout=GNU' '--without-pear' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dom' '--with-enchant' '--enable-exif' '--with-gettext' '--with-gmp' '--enable-fileinfo' '--enable-filter' '--enable-ftp' '--enable-hash' '--with-iconv' '--enable-mbregex' '--enable-mbregex-backtrack' '--enable-mbstring' '--enable-phar' '--enable-posix' '--with-mcrypt' '--enable-mysqlnd-compression-support' '--with-zlib-dir' '--with-openssl=yes' '--with-libedit' '--enable-libxml' '--enable-session' '--enable-simplexml' '--enable-soap' '--enable-sockets' '--enable-tokenizer' '--enable-xml' '--enable-xmlreader' '--enable-xmlwriter' '--with-xmlrpc' '--with-xsl' '--with-mhash=yes' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-zip' '--with-system-tzdata' '--with-gd' '--enable-gd-native-ttf' '--with-jpeg-dir' '--with-xpm-dir' '--with-png-dir' '--with-freetype-dir' '--with-vpx-dir' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--disable-dtrace' '--enable-pdo' '--enable-mysqlnd' '--enable-pcntl' '--with-recode=shared,/usr' '--with-sqlite3=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--with-pdo-dblib=shared,/usr' '--with-ldap=shared,/usr' '--with-ldap-sasl=/usr' '--enable-intl=shared' '--with-snmp=shared,/usr' '--enable-json=shared' '--with-pgsql=shared,/usr' '--with-pdo-pgsql=shared,/usr' '--enable-opcache' '--enable-opcache-file' '--enable-huge-code-pages' '--with-imap=shared,/usr' '--with-kerberos' '--with-imap-ssl=yes' '--with-mysqli=shared,mysqlnd' '--with-pdo-mysql=shared,mysqlnd' '--with-tidy=shared,/usr' '--with-pspell=shared,/usr' '--with-curl=shared,/usr' 'build_alias=x86_64-linux-gnu' 'host_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fdebug-prefix-map=/tmp/buildd/php7.3-7.3.3=. -fstack-protector-strong -Wformat -Werror=format-security -O2 -Wall -fsigned-char -fno-strict-aliasing -g'Server APILiteSpeed V7.2Virtual Directory SupportdisabledConfiguration File (php.ini) Path/usr/local/lsws/lsphp73/etc/php/7.3/litespeed/Loaded Configuration File/usr/local/lsws/lsphp73/etc/php/7.3/litespeed/php.iniScan this dir for additional .ini files/usr/local/lsws/lsphp73/etc/php/7.3/mods-available/Additional .ini files parsed/usr/local/lsws/lsphp73/etc/php/7.3/mods-available/01-ioncube.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/40-apcu.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/40-igbinary.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/40-msgpack.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/40-solr.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/50-memcached.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/50-redis.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/curl.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/imap.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/intl.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/json.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/ldap.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/mysqli.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/opcache.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_dblib.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_mysql.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_pgsql.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_sqlite.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pgsql.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pspell.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/recode.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/snmp.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/sqlite3.ini, /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/tidy.iniPHP API20180731PHP Extension20180731Zend Extension320180731Zend Extension BuildAPI320180731,NTSPHP Extension BuildAPI20180731,NTSDebug BuildnoThread SafetydisabledZend Signal HandlingenabledZend Memory ManagerenabledZend Multibyte Supportprovided by mbstringIPv6 SupportenabledDTrace SupportdisabledRegistered PHP Streamshttps, ftps, compress.zlib, php, file, glob, data, http, ftp, phar, zipRegistered Stream Socket Transportstcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2Registered Stream Filterszlib.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk

This program makes use of the Zend Scripting Language Engine:
Zend Engine v3.3.3, Copyright (c) 1998-2018 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.3.0, Copyright (c) 2002-2018, by ionCube Ltd.
with Zend OPcache v7.3.3-2+stretch, Copyright (c) 1999-2018, by Zend Technologies
Regards
Mariusz Pulkowski
 
#5
He,
Maybe the solution would be to uninstall lsphp completely and reinstall only one version of lsphp7.3?
Question about socket php, is it added together with lsws or lsphp?
Maybe then in each MOODLE module the identification of the lsphp version would be the same.

Today LSWS stopped again. Within 24 hours I counted about 40 unclosed CRON processes (it is called every minute).
Regards
Mariusz Pulkowski
 
#6
He,
In the litespeed forum I found similar behavior described, the solution was to uninstall some module causing the problem. Following this lead, I built MOODLE again, bypassing those modules incompatible with the version of PHP supported. The main problem seems to be solved.
At some server load, from time to time an error appears with information about the incorrectly configured lsphp_mysqli plugin.
The effect of each occurrence are unclosed mysql processes. After two days there are 60 processes.
Maybe you have any idea how to check the correct configuration of the MySQLi module. It seems to be correct but ...?
Regards
Mariusz Pulkowski
 
Top