Trying to make reCaptcha work on Directadmin

So I followed the official guide on how to enable reCaptcha protection:

This is my my file: /usr/local/lsws/conf/httpd-lsrecaptcha.conf
Apache config:
lsrecaptcha  {
  enabled                 1
  siteKey                 xxx
  secretKey             xxx
  type                    2
  maxTries                3
  allowedRobotHits        3
  botWhiteList  {
 regConnLimit            15000
 sslConnLimit            10000
I then added a custom rule to all Virtual hosts using the template at: /usr/local/directadmin/data/templates/custom/cust_openlitespeed.CUSTOM.5.pre
Apache config:
RewriteCond %{REQUEST_URI} ^/wp-login\.php$
RewriteRule .* - [E=verifycaptcha: drop]
Then rewrote confs
cd /usr/local/directadmin/custombuild
./build rewrite_confs
Now, when I try to trigger the reCaptcha at wp-login page, it loads normal (no recaptcha). I even tried using a Tor browser, and one site's Jetpack protection got triggered, but not the Recaptcha.

I'm using recaptcha v2, the Checkbox type. With the setting "Verify the origin of reCAPTCHA solutions" disabled.
It's a Directadmin server, with more than a few sites. I'm using Cloudflare on most sites, but I also tested on sites without CF and got the same result. For some reason, the httpd-lsrecaptcha.conf file got reverted to default at some point. I guess when I rewrote conts?

Any help would be appreciated.
Short update:
I tried setting the regConnLimit and sslConnLimit to "1" and turns out, recaptcha is working, but the type is wrong. The Checkbox on v2 is type 1. After that correction, it was triggered as expected.
So now, my question is more specific, what's wrong with the custom rewrite rule on the Virtual hosts?
Second update:

I simplified the rewrite rule (I guess I don't need a conditional) to:
Apache config:
RewriteRule ^/wp-login\.php$ - [E=verifycaptcha: drop]
Still nothing.
I know at this point I'm basically spamming my own post, but there is no edit button and maybe someone has suffered the same ordeal as me.

The last edit threw an error

[(null)] rewrite: Unknown rewrite rule flag while parsing: rewriterule ^/wp-login\.php$ - [E=verifycaptcha: drop]