Unable to enable HTTP/3

I installed OpenLiteSpeed Web Server 1.7.17 on Ubuntu 22.04.2 and Enabled HTTP/2 and HTTP/3 in all levels (server, listener, virtualhost) for included example site. However the site is loading with HTTP/2 only, I can see alt-svc advertising h3

Alt-Svc: h3=":443"; ma=2592000

What am I missing?
Could you test the site on https://http3check.net/ and share the output here?
I am currently working for my Master's thesis, I do not have a registered domain or IP so, I am testing in localhost environment. Therefore, I could not test with the site you mentioned.

But I figured out the issue, the OLS configuration was absolutely fine. The issue was with Chrome. In wireshark capture, I noticed "Crypto error" "Certificate Unknown" error from client side.

It seems Chromium/Chrome does not allow the use of custom CA for QUIC (https://sites.google.com/a/chromium.org/dev/quic/playing-with-quic) (https://groups.google.com/a/chromium.org/g/proto-quic/c/aoyy_Y2ecrI/m/R-Mdl9noBAAJ). I tried to load the site with Firefox and it loaded with HTTP/3. I also tried to load the site using chrome and the flags mentioned in the above site to bypass this check, but it is still failing.

Does anyone know how to circumvent this behavior of Chrome? I intend to take performance measurements of HTTP/2 and HTTP/3 using google lighthouse.