Unexplainable and not always replicable error

Hello. I create this post because I need help to resolve an apparently unsolvable issue!

I have a ubuntu 20.04 server with Openlitespeed with Runcloud panel.
The theme of the site is Buddyboss (Comunity online). I own two sites and on both of them I have the same problem.
The sites are on the same server.
It has been a month and a half that I have encountered this error and cannot resolve it. I involved both Theme support and Server support (Runcloud) but didn't fix anything.

I explain the problem:

On my side, if I publish a youtube link on the news feed (activity foreseen for site subscribers), the post that follows is a white post (empty), when for which I should get a preview of the link itself. (I live in Italy). If I do it from a pc unrelated to me (for example from a pc of my friends), I get the same result.

This does not happen on the assistance side (they do not reside in Italy).
They seem to be able to publish any youtube link without any problems.
I wonder, how could such a thing happen?

I have tried with both LScache plugin on and off.

Well if I open dev tools several third party errors are encountered. First of all, errors related to cookies (samsite).
I tried to add code snippets to the .htaccess file like this:
<IfModule LiteSpeed>
ForceSecureCookie secure same_site_none
I also managed to add it to the Litespeed Server configuration file that Webapp.
I have not noticed any improvement.

In practice I find myself with an error (not only from my pc, but also from pc not mine and not directly connected to the main connection but), which the customer service seems to detect.

I ask for help because in my opinion, it is an active or missing setting on the server side.

Thank you


So the issue is a youtube link on the news feed can not preview? and it happens even LSCWP is disabled?
Possible to share the issue link or page here so we can take a look?
The problem was brought to the attention of the server manager (Runcloud) and the developer of the main theme (Buddyboss).
The errors on devtools apparently are found only by me (I tried to change pc and connection to see if they actually dirpendersi from my pc but the error persists).

When a link (youtube) is copied and pasted on a post, the preview is created (and so far everything is regular also on my side), but when I go to publish the preview it disappears posting only an empty content (the preview that should have been posted disappears). If I open devtools and activate the third party functions I will encounter errors related to Samsite and sometimes also an error 410 (I am attaching some photos of dev tools, the site is still offline for the public but it would be ready to go online).

The assistences does not have this problem and calmly post the content without errors.

It also occurred to me that the difference could be the country of residence (the PCs I tested are in Italy), both the assistance (Server and theme) contacted are outside the EU, and regarding this I added this snippet to the ht access file to see if I solved:
RewriteRule .* - [E=Cache-Vary:%{ENV:LSCACHE_VARY_VALUE}+euCookie]

But I haven't solved anything.

The particular thing that even on the other site (which is basically a copy of the first one) I have the same problem. Both sites are on the same server (OLS).


Hello and thanks for the reply!

The site is called: fuocofisso.org
(it is a site closed to the public - it is a social network not yet started - it is accessed by registration and the news feed is inside).

What about all those mistakes about cookies? I think it's not normal to have them!

Thank you!


OpenLiteSpeed only recognize Rewrite, so ForceSecureCookie secure same_site_none will not work but
RewriteRule .* - [E=Cache-Vary:%{ENV:LSCACHE_VARY_VALUE}+euCookie]

Even you bring a copy to the cache copy, it should as nothing to do with the empty display. Maybe we can help to take a look after you published the site or maybe you could send a support request to support@litespeedtech.com with more information.