unixODBC Driver Manager Can't open lib file not found --but file is there


New Member
Hi, Litespeeders! I've been having such a difficult time pinpointing a problem. I installed the sqlsrv extension on an Ubuntu 20.4 running php 8.1 (of three php versions on the server) and I have hit a wall with this error:

[unixODBC][Driver Manager]Can't open lib '/opt/microsoft/msodbcsql18/lib64/libmsodbcsql-18.3.so.2.1' : file not found

The strange thing is that the file is there. I tried adding it to the www-data group but it still says file not found. Is there some sort of PATH variable it is supposed to go in for each php version?

Some things I've tried:
  • Looked at etc/odbc.ini but it is empty
  • Checked the library dependencies of /opt/microsoft/msodbcsql18/lib64/libmsodbcsql-18.3.so.2.1 and they are all mapped to their various x86_64-linux-gnu/...files, mostly shared objects
  • Tested it with AppArmor disabled but that didn't work
  • Restarted OLS tons of times
I don't normally have a remote Windows SQL server associated with any of the OLS servers but am trying to let a client use one. Any insight on where else to look would be sincerely appreciated. Thank you so much!