Use Client IP



I'm having some problems getting the 'Use Client IP Header' to work.

I have nginx on the front-end to proxy requests to LiteSpeed on the same server. On nginx I have enabled:
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

and I can confirm by viewing phpinfo.php that the following two headers are correctly amended with the corrent user's IP:

on LiteSpeed I have enabled the option to use the client IP in Header, but it still only logs requests as

Any idea as to what I'm doing wrong?


Active Member
Howdy Athalas,

Sorry for letting this sit so long, but it was at the end of the page and.. Alright, that's not a good excuse at all.

Anyway, this is a bug. Thank you for reporting it. We've got it in the system now and we're working on it.