Virtual host SSL

#1
Hello all.

I'm using openlitespeed for my webserver, I can configure listener with SSL. But I have 2 domain and 2 virtual host with different SSL certificate. How to configure SSL for virtual host with per SSL cert for one virtual host, but using one port 443 for client ?

Thanks you very much for all your support.
 

lsfoo

Administrator
#2
Hi vuvps,

Assuming you're using the web admin, after you initially set up your two virtual hosts (and save and restart the server), you can further configure them both to use a specific SSL cert.

Once they both have the certs added, go to your SSL Listener configuration and add the vhosts to the Virtual Host Mappings. You can specify the domains here.

Let me know if this helps or if you have further questions,
Kevin
 
#4
i have the same problem, so i assume the steps are like this right?
1. create 443 listener and set secure to yes
2. map virtual host 1 and virtual host 2 to 443
3. configure ssl at virtual host
4. graceful restart
 

lsfoo

Administrator
#5
Hi fadhilah,

Yes, that should work. The main thing to note is that the domains must be different. (i.e. they both can't be example.com.)

Let me know if you have any issues,
Kevin
 
#6
1 . I install OpenLiteSpeed 1.4.25, virtual host 1 and virtual host 2
2. create 443 listener and set secure to yes
3. map virtual host 1 and virtual host 2 to 443
4. configure ssl at virtual host for virtual host 1 and virtual host 2
5. graceful restart

But check netstat -tnl port 443 not connect, so 2 site ssl virtual host 1 and virtual host 2 not access https://

If I config like bellow

1. create 443 listener and set secure to yes
2. Listener 443 > SSL -> config ssl CERT, Private key for virtual host 1
3. map virtual host 1 to 443

access https://host1 ok.

But map virtual host 2 to 443, access https://host2 not trust ssl.

Please help me.
 
#11
Hi,

I am having an issue on vhosts with SSL. I intended to have multiple vhosts with SSL, so I define the location for the certs at VHOST level and try to set the SSL path of the listener, I cannot put relative path except only $SERVER_ROOT, the rest cannot, so I can't have a template based SSL path, it only works with absolute path.

Am I missing something?

Any guide that I can refer to?
 
Last edited:
Top