Almalinux 8.6 failed to update ImageMagick-libs

Sveken

New Member
#1
Hello all,
I have about 6 Almalinux + Openlitespeed boxes which have been working great so far.

However i am unable to update any of them currently due to the imagick components we are using for lsphp due to the following errors

Problem 1: package lsphp80-pecl-imagick-3.4.4-1.el8.8.0.x86_64 requires libMagickCore-6.Q16.so.6()(64bit), but none of the providers can be installed
- package lsphp80-pecl-imagick-3.4.4-1.el8.8.0.x86_64 requires libMagickWand-6.Q16.so.6()(64bit), but none of the providers can be installed
- cannot install both ImageMagick-libs-6.9.12.48-2.el8.x86_64 and ImageMagick-libs-6.9.10.86-1.el8.x86_64
- cannot install the best update candidate for package lsphp80-pecl-imagick-3.4.4-1.el8.8.0.x86_64
- cannot install the best update candidate for package ImageMagick-libs-6.9.10.86-1.el8.x86_64

The repos installed are


repo id repo name
appstream AlmaLinux 8 - AppStream
baseos AlmaLinux 8 - BaseOS
epel Extra Packages for Enterprise Linux 8 - x86_64
epel-modular Extra Packages for Enterprise Linux Modular 8 - x86_64
extras AlmaLinux 8 - Extras
litespeed LiteSpeed Tech Repository for CentOS 8 - x86_64
litespeed-update LiteSpeed Tech Update Repository for CentOS 8 - x86_64

which i believe are correct?

Thanks,
 
#4
Hi, this is happening in Rocky Linux and Alma Linux as well. Also with LiteSpeed Enterprise not only OpenLite Speed. Unfortunately the solution provided by adson.junio does not work, as it breaks other packages. Hope to see this fixed soon.
 
Top