binding IPv6 showing ::ffff:


New Member
Hi there,

Using OpenLiteSpeed 1.6.13 on Ubuntu 18.04.

I have some issues regarding binding on IPv4+IPv6, REMOTE_ADDR, and SERVER_ADDR, is showing ::ffff:ipv4-address.
I did try setting up listeners individually for IPv4 and IPv6, problem persists.

Searched the forums and saw that this issue was in 2013, is there any fix for getting this working as it should?


OLS should work with both ipv4 and ipv6 without any problem. Can you show your listener configuration? How to verify your issue?


New Member

Our listeners are configured using [ANY]:

More specifically:

listener HTTP {
  address                 [ANY]:80
  binding                 15
  secure                  0
  map                     domain.tld *

listener HTTPS {
  address                 [ANY]:443
  binding                 15
  secure                  1
  keyFile                 /etc/ssl/private/domain.key
  certFile                /etc/ssl/private/domain.crt
  certChain               1
  renegProtection         1
  sslSessionCache         1
  sslSessionTickets       1
  enableSpdy              15
  enableQuic              1
  map                     domain.tld *
This, for the most part, works just fine.

Except that in some specific situations, some clients that are using IPv4 only stacks get their addresses mapped as ::ffff:

This in turn, somehow, we haven't figured out exactly WHY, is messing up our WHMCS license, and it renders it invalid.

We force update it, it works, then it somehow breaks again when a specific colleague accesses the admin section and gets his IPv4 address mapped as a V6 address, again.

So far we have concluded that if we disable IPv6 completely, the problem doesn't show up at all. Also when we used nginx or Apache, we never had this problem.

Our only guess is that it happens because IPv4 addresses get mapped as IPv6 sometimes (we can see visitors IP addresses getting mapped as IPv6 all the time under OpenLiteSpeed).

Is there any way to disable this functionality at all?