Build Error


Frank Feingold


I'm trying to build OpenLiteSpeed 1.0.4 on a Mac and I'm getting the following error:

n file included from poolalloc.cpp:18:
../../src/util/poolalloc.h:77:16: error: cannot initialize return object of type
'char *' with an rvalue of type 'void *'
return m_pPool->allocate( _Size );

I tired using both ports and brew and get the same error either way.



Active Member
Frank! How ya doing?

So I tried reproducing this and didn't run into any problems. Admittedly, our implementation on OSX with these early versions is sketchy, but the techs think it might have something to do with different versions of gcc. I used 4.2.1. What are you using?

Last edited:

Frank Feingold

Hello Michael,

Doing just fine.

gcc??? The install guide says to install Xcode (, which is Apple's development environment. I'm using their compiler:

$ cc -v
Apple LLVM version 5.0 (clang-500.2.75) (based on LLVM 3.3svn)
Target: x86_64-apple-darwin12.5.0
Thread model: posix

Based on your comments I'm guessing I should be installing gcc from ports or brew?


Active Member
Hm. Yes, I would say so. Though I (and I think all the tech guys) were getting our OSX versions of gcc from the "Command Line Tools for Xcode" on the Apple site:

We're going to tool around with installing different gcc versions to in the port command. I was trying to use port install gcc47, but it doesn't seem to work so well...

Obviously, we need to include this in the install guide. Port would be a nicer way of doing it, but, for now, I'll tell people they need Xcode's command line tools.