FreeBSD not supported

Discussion in 'Other Support: MacOSX, FreeBSD etc' started by Chris., Feb 5, 2014.

  1. Chris.

    Chris. Guest

    Greetings,
    I've spent the last couple of days attemting to build, and install OpenLiteSpeed. Sadly ./configure fails to find the installed copy of pcre. In my attempts, I tried all versions starting from 1.2.9, all the way to version 1.0.4. Each failed during the ./configure process. All the prerequisites are already installed on my system. For clarity, following are the details, in hopes that OpenLiteSpeed development can correct this, or perhaps provide some suggestions.
    Code:
    gcc version:
    Using built-in specs.
    Target: amd64-undermydesk-freebsd
    Configured with: FreeBSD/amd64 system compiler
    Thread model: posix
    gcc version 4.2.1 20070831 patched [FreeBSD]
    
    autoconf 2.69
    
    automake 1.14
    
    pkgtools (pkgconf) 0.94
    
    pcre 8.33
    
    Complete inventory of pcre:
    
    /usr/local/bin/pcre-config
    /usr/local/bin/pcregrep
    /usr/local/bin/pcretest
    /usr/local/include/pcre.h
    /usr/local/include/pcreposix.h
    /usr/local/include/pcre_scanner.h
    /usr/local/include/pcre_stringpiece.h
    /usr/local/include/pcrecpparg.h
    /usr/local/include/pcrecpp.h
    /usr/local/lib/libpcre.a
    /usr/local/lib/libpcre.la
    /usr/local/lib/libpcre.so
    /usr/local/lib/libpcre.so.3
    /usr/local/lib/libpcre16.a
    /usr/local/lib/libpcre16.la
    /usr/local/lib/libpcre16.so
    /usr/local/lib/libpcre16.so.2
    /usr/local/lib/libpcre32.a
    /usr/local/lib/libpcre32.la
    /usr/local/lib/libpcre32.so
    /usr/local/lib/libpcre32.so.0
    /usr/local/lib/libpcrecpp.a
    /usr/local/lib/libpcrecpp.la
    /usr/local/lib/libpcrecpp.so
    /usr/local/lib/libpcrecpp.so.0
    /usr/local/lib/libpcreposix.a
    /usr/local/lib/libpcreposix.la
    /usr/local/lib/libpcreposix.so
    /usr/local/lib/libpcreposix.so.0
    /usr/local/libdata/pkgconfig/libpcre.pc
    /usr/local/libdata/pkgconfig/libpcre16.pc
    /usr/local/libdata/pkgconfig/libpcre32.pc
    /usr/local/libdata/pkgconfig/libpcrecpp.pc
    /usr/local/libdata/pkgconfig/libpcreposix.pc
    
    configure output (failure with some context):
    
    checking for openssl/ssl.h in /usr/local... no
    checking for openssl/ssl.h in /usr/local/ssl... no
    checking for openssl/ssl.h in /usr... yes
    checking whether compiling and linking against OpenSSL works... yes
    checking lib pcre... (testing)
    checking for pcre_study in -lpcre... no
    checking for pcre_compile in -lpcre... no
    checking lib pcre... no, (WARNING)
    configure: error: Can not find pcre. You must install it before continuing.
    
    While I must admit my autotools foo is a bit rusty, it really doesn't appear OpenLiteSpeed supports FreeBSD.

    Thank you for all your time, and consideration.

    --Chris
     
  2. Chris.

    Chris. Guest

    OK. Closer examination reveals it's FreeBSD (64bit), that's not supported.
    It's hard to imagine why anyone would choose 32bit, over 64. Anyway, I'll have
    patches that'll apply to the source, in order to fully support FreeBSD i386/AMD64,
    after a bit more testing.

    --Chris
     
  3. lsmichael

    lsmichael Active Member

    Should have realized this when I first saw the post. To fix this, you just have to tell configure where to look for pcre:

    Code:
    ./configure --with-pcre=/usr/local
    Thanks, @Chris. for pointing this out and for emailing when I didn't get in touch. This point has been added to the installation documentation as a note.

    m
     
  4. Rob

    Rob New Member

    This is an old post but it made 'configure' work for me. However, 'make' will fail with the error
    This is on FreeBSD 11.1-RELEASE

    I tried doing
    Code:
    ./configure --with-pcre=/usr/local --with-openssl=/usr/lib
    
    
    because that's where libssl.a actually is on my FreeBSD but that's as far as I've gotten at the moment unless someone can give a little help. I also couldn't find the above mentioned documentation mentioned in the post.

    EDIT: Yes, I just noticed the error says it tried to "make" libssl.a which isn't what we want so I can't think about that at the moment.
     
  5. Pong

    Pong Administrator

    For FreeBSD 11, you need to run
    Code:
    cd /usr/ports/perl5.26; make install clean; rehash;
    then:
    Code:
    ./configure --with-pcre=/usr/local
    OLS will handle openssl part itself.

    Let us know if there is any further issue.
     
  6. Rob

    Rob New Member

    Well, all that was already done as shown in my question. The problem is that openLiteSpeed did not handle openssl and gave the error:
     
  7. Pong

    Pong Administrator

    Where did you download OpenLiteSpeed? Souce code in github master branch doesn't support FreeBSD. You will need to choose other branches such as:

    Try 1.4 branch https://codeload.github.com/litespeedtech/openlitespeed/zip/v1_4. We tested it on FreeBSD 11.1 and it should work.
    If not, you can log a ticket with us by providing your server tmp root access. we can take a look.
     
  8. Rob

    Rob New Member

    The version you linked to installs. Thanks. Originally I downloaded the "current version" from here.

    I tried to start it but get an error I haven't looked into yet. I'll open a different thread after researching it a bit.
    I do have that lib at that location but I don't know about the CSSABI part.
     
  9. Pong

    Pong Administrator

    maybe we need to login to your system to take a look. our installation test doesn't show such error.
     
  10. Rob

    Rob New Member

    I got this working. On my workstation, libstdc++.so.6 is used by openLiteSpeed in /usr/local/compat but that is an older version for backwards compatibility with Linux and other systems. I needed to add LD_LIBRARY_PATH to point to /usr/local/lib/gcc6 for this to work.
     

Share This Page