GZIP/Brotli Compression turned on, content still served uncompressed


I have an instance of an OpenLiteSpeed server with Wordpress installed (including the LS cache plugin for Wordpress). I have enabled the gzip/brotli compression as per the screenshot below:
Schermafbeelding 2020-06-01 om 11.39.54.png

Also compression is enabled in the virtual host configuration of my domain.

But when I request the homepage and check the network tab in chrome dev tools none of my assets (css/js) files are encoded with either gzip or brotli. While the request is made with the accept header: accept-encoding: gzip, deflate, br

Also have an screenshot of the request/response:
Schermafbeelding 2020-06-01 om 11.41.59.png

Also tested the domain with other tools. Google Page Speed and GTMetrix both say none of the files are compressed and I should add compression.

How is the server not compressing the files or serving the compressed files?


Active Member
gzip and br compression is only for static file. If a URL is handled by php, then it will be depended on the php. Also cache or proxy may change.
You can toggle the debug log and do one test again. and grep the log to see the reason, or send to us.
It seems to be a problem with the pagespeed module for Litespeed (modpagespeed). When I disable this mod suddenly all the assets are compressed. Probably something to look into.